Cannot create vpnc connection with nm-connection-editor, xfce


I am trying to use the nm-connection-editor with xfce to setup a vpnc connection.

I am trying:

  • Left Click Network-Manager → VPN-Connection → Add a vpn-connection… → select vpnc → set Gateway, Username, Groupname and Passwords → Save-Button is grayed out
  • Right Click Network-Manager → Edit Connections → ± Button> same as above
  • run gksu nm-connection-editor → same as above

It seems like I am missing an mandatory field but I cannot imagine which one.
Please let me know if I am doing something wrong or if you may face the same problem.


  Kernel: 5.15.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Processes: 388 Uptime: 54m wakeups: 10119 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1353
  lib: 411 flatpak: 0 Shell: Bash (sudo) v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.13

network-manager window with grayed out save-button:

Thank you,

If it can’t save, there’s a setting invalid.
Verify that you entered all details that are required.

I had the same problem.

I changed this morning from Manjaro KDE to Cinnamon.

No Problem in KDE environment.
In Cinnamon Save Button wasn´t activ.

With Try and Error Method I found out, that if I add in “Advanced” Tab under Domän also “some.gate.way” and in Interface “tun0” and set the hook for “Peer to Peer…” the Save Button was activ.

VPN Connection is now working as expected.

In started Networkmanager via gksu and allow connection for all users. Password saved for all users.


1 Like

That works fine … thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.