Cannot connect to Windows shares in Manjaro Cinnamon

Nemo file manager sees the windows hosts. After double clicking the hosts I get a pop-up notification that says its opening and that I can stop this operation by clicking a cancel button which is located at the bottom of the pop-up notification window. The process never completes the connection and so I can never select any shares to access. There are no authentication options presented to me either. On the Windows hosts there are no active sessions. Here is the odd part for me. I have another partition with Manjaro KDE edition installed. The KDE install sees the windows shares and behaves normally when double clicking the hosts to all access the shares. Anyone have ideas why there is a difference in behavior and how do I rectify this in Cinnamon?

Hello @ghoultek :wink:

At least what I can say quickly:

  1. Cinnamon → Nemo uses gvfs-smb its own plugin as backend to connect to a samba share.
  2. KDE → Dolphin uses kio-fuse as backend to connect to a samba share.

So the backend is different.

1 Like

Thanks @megavolt . Is there a way to correct the behavior in Cinnamon so that it matches the behavior found in KDE? The only change I made after a fresh install is install updates.

Oh man I checked again… Nemo has its own Plugin and does not use gvfs-smb …

nemo-extensions/nemo-share at master · linuxmint/nemo-extensions · GitHub

However… I don’t use samba, because it is too slow, but try to run nemo on the terminal and watch its output. Maybe there is a hint? Also keep sure the package nemo-share is installed.

Thanks @megavolt. I will have to try the Linux Mint forums to see if they have a means of fixing the issue.

What are you using to connect to Windows shares?

Samba = Windows share

Windows share uses the Samba Protokoll. And no, Samba does not invent it, but Microsoft named it like this and on Linux it just Samba.

However… I don’t use Windows share or Samba. Since Windows 10 und Linux have OpenSSH on board (yes Windows have it in its features), I would just use sftp over ssh for file transfer with a private key. This can also be used, when you are not behind a NAT and it still works and is secure by default. Just the IP have to be adjusted.

But if I have to use the Samba Protokoll, I would use it like this here: Since this works on any Distribution the same way.

1 Like


Thanks again. I hopped over to the Linux Mint forums to see if they had some additional insight. It turns out that the SMB browse feature (discovery) is broken on the latest Mint (v20.2). Based on what you stated and what the other person stated its best to use explicit share paths because the discovery feature was dependent on SMB1 which has a security flaw in it. Because of the security flaw it was disabled by default. The Linux Mint implementation of Cinnamon provides an error message in a pop-up notification, while the Manjaro Cinnamon implementation does not. I’m guessing there would be an error message in a log on the Manjaro Cinnamon side.

For now I’ll stick with KDE in which the discovery feature works, and look into openSSH. I prefer Manjaro of Mint.

Is the Cinnamon installation missing a /etc/samba/smb.conf file? If it’s not there you might need a package called manjaro-settings-samba.

I believe it was missing, but I deleted the partition and installed KDE clean.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.