Cannot connect to GitHub, Twitter, etc. Unable to connect to Server

Hi there,
I had installed Arch Linux on my system and wanted to install yay… But after a while I found out I can’t connect to GitHub at all. Now I tried it with Manjaro and still cannot access the site (I only did this because I don’t know how to find out the answer needed for the registration on Arch forum. If you can help me to get it I’d appreciate it).
Sites like DuckDuckGo, Twitter and GitHub don’t wanna connect. YouTube and Google however work just fine. If you can help me it would be really nice.


PS: I think it is something with my network configuration like DNS and such since I can connect to the sites from my main PC.

Hi @JLK2506, and welcome!

It does sound like some kind of DNS issue. Do you know if the 2 machines have the same DNS setting?

That would bee my guess, as to why this is happening. Try and set the problematic one’s primary DNS server to (You can change it later if you don’t want to keep it.)

1 Like

I went into the connection settings and set as my DNS server under Other DNS Servers in both IPv4 and IPv6. Still doesn’t connect…

Please post the output of

curl -v -o testfile

If dig command is not found, install the package bind

Encapsulate the output text with three backticks ``` (beginning and end)

Uhhhh… So I tried the dig command… It wasn’t found and as I did pacman -S bind it gave out the following:

warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
error: target not found: bind```
sudo pacman -Syu bind

Only gives out the following:

error: failed to update extra (no servers configured for repository)
error: failed to update community (no servers configured for repository)
error: failed to update multilib (no servers configured for repository)
error: failed to synchronize all databases```

You don’t seem to have any mirrors configured :thinking:

sudo pacman-mirrors --geoip

then install again

Thanks… I did retype the command and it also made a full system update. But so it also updated Network Manager and then I restarted to see if it would work and still can’t connect. But at least I can run the two commands you mentioned.

dig gives:

; <<>> DiG 9.16.13 <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57563
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 512
;                    IN      A

;; ANSWER SECTION:             59      IN      A

;; Query time: 10 msec
;; SERVER: fd00::f2b0:14ff:fe31:32c0#53(fd00::f2b0:14ff:fe31:32c0)
;; WHEN: So Mai 02 13:56:28 CEST 2021
;; MSG SIZE  rcvd: 55```

```curl -v -o testfile``` gives:
```  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0*   Trying
* Immediate connect fail for Network is unreachable
* Closing connection 0
curl: (7) Couldn't connect to server```

PS: Ending these backticks doesn't seem to work properly...

looks like some routing issue.

please post route

bash: route: command not found

What do I need to install in order for it to work?


also post nmcli

route output is:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface U 600 0 0 wlp3s0

And nmcli gives me:
wlp3s0: connected to FRITZ!Box 7560 ST
“Qualcomm Atheros AR9285”
wifi (ath9k), D0:DF:9A:D4:D9:29, hw, mtu 1500
ip6 default
inet6 2003:d7:7f43:fc00:1a1a:f5ab:cd5f:6950/64
inet6 fe80::6bb5:1653:3b8a:fcd/64
route6 2003:d7:7f43:fc00::/56
route6 2003:d7:7f43:fc00::/64
route6 ::/0
route6 ff00::/8
route6 fe80::/64

p2p-dev-wlp3s0: disconnected
wifi-p2p, hw

enp5s0: unavailable
“Realtek RTL8111/8168/8411”
ethernet (r8169), E0:69:95:76:5E:33, hw, mtu 1500

lo: unmanaged
loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
servers: fd00::f2b0:14ff:fe31:32c0 ::ffff:
interface: wlp3s0
domains: Repeater
interface: wlp3s0

Use “nmcli device show” to get complete information about known devices and
“nmcli connection show” to get an overview on active connection profiles.

Consult nmcli(1) and nmcli-examples(7) manual pages for complete usage details.

You seem to be missing the default route. How did you setup the network connection?
Did you put a static IP rather using DHCP?

Also what is weird is that you are in network and your first DNS server is
By default the fritz boxes should have

I’m using DHCP

What’s the address of your router? to me this looks you messed something up on the router.

The IP of the router is At least it should be… Since I didn’t change anything on the router

This is odd, you should be in the same network then rather than
Did you modify the DHCP server settings on the fritzbox?

Anyways, try this command route add default gw wlp3s0

I’m guessing that IPv4 is misconfigured and some things work through IPv6. But it’s just an idea.

Yeah, he is missing the default v4 route and only IPv6 is working which is why he can connect to certain websites.