Cannot click on launcher or panel

I recently changed my Plasma desktop to the Wayland protocol and now I cannot click on any panels any more. I have already reset to the standard Plasma panel and starter, so it looks like this:

However, the click events seem to be eaten up. I can click anywhere else (Desktop, Applications, and interact with them normally. It’s just the panels that don’t work.

To test, I have created a new test user on my system. When I log in with that user, everything works normally. I can left-click anywhere.

Any ideas?

Remove plasma related configuration files from user ordinary user.


Hm. Not sure which ones are “plasma related configuration files”.

I already tried editing ~/.xinitrc. I reverted it to the file from the new user. No luck so far. What else could I try?

What is your setting in “Settings > Window Management > Window Behavior > Window Actions > Left click”?

I prefer the “Activate and raise” option when using X11, but apparently Wayland has a problem if “pass click” is not also included and results in symptoms similar to what you descrbe.

1 Like

Hello @Takakage Thank you so much! I would never have discovered that and would have never considered to switch that option. Indeed, like you, I also prefer the “Activate and raise” option. Maybe as the panels never have focus, they never get the click then. However, on X11, it always worked with that option.

Hope this bug will be fixed soon. Until then, I’m going to use the option passing the click.

Thank you so much!

Yeah, I spent several hours pulling out my hair in perplexed frustration when I encountered the problem. I’m glad to have spared someone else at least some of that experience.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.