Cannot Change Screen Brightness - NVIDIA GPU

I have a NVIDIA GPU and a CPU with integrated graphics.

I booted up my system this morning and I was unable to change the brightness. Whenever I press the brightness +/- keys the brightness change indicator would pop up but there wouldnt be any change in brightness. In /etc/default/grub I’ve tried variants of adding acpi_backlight=$VALUE (vendor, native, none) into GRUB_CMDLINE_LINUX_DEFAULT and GRUB_CMDLINE_LINUX="" and none of them worked.

After looking through some other forums I tried echo 10 | sudo tee /sys/class/backlight/amdgpu_bl1/brightness and that worked. I’m still not sure why nothing else is working though.

What is the output of ls /sys/class/backlight/?

Are you using hybrid driver or NVIDIA only driver?

The output was

amdgpu_bl1 nvidia_0

I am using the video-hybrid-amd-nvidia-prime driver

Ok, since you’re using the hybrid driver one, the amdgpu_bl1 is the one used mainly to control the display.

Just to make sure first, check if there’s no error found in sudo dmesg.

Then try enabling native backlight:

  1. sudo nano /etc/default/grub
  2. Add “video.use_native_backlight=1” to GRUB_CMDLINE_LINUX_DEFAULT, for example GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash … OTHER_CURRENT_ENTRIES_HERE … video.use_native_backlight=1”
  3. sudo update-grub
  4. Reboot

If this doesn’t work, then you probably need to update some of the system xorg conf file.

You will likely find it in ls /usr/share/X11/xorg.conf.d/.

You may need to update one of the X server configuration file here, the one with:

Section "OutputClass"
    Identifier "AMDgpu"
    MatchDriver "amdgpu"
    Driver "amdgpu"
EndSection

I use NVIDIA only for display, so I can’t tell what kind of brightness options to add to the AMDgpu section for your case.

References:
https://www.x.org/releases/current/doc/man/man5/xorg.conf.5.xhtml
https://wiki.archlinux.org/title/AMDGPU

Adding video.use_native_backlight=1 set the brightness to 100% (still unable to change it manually) and actually changed the name of the folder amdgpu_bl1 to amdgpu_bl0. From what I can tell there is no error found in sudo dmesg

I’ll try and look up what to add to the xorg conf files

Update: I am still unsure how to solve this and I really don’t want to mess something up

I find this issue comes and goes over the years with changing kernels/kernel updates.

I eventually just rolled back to a previous version of my system via Timeshift and that seemed to work.

Through some trial and error I discovered that this brightness issue only happens after I update my system so I will not be doing that anytime soon. I don’t know which package could be breaking the brightness though I suspect the following package updates to be a possibility for causing this issue:
manjaro-release 23.2.3-1, nvidia-utils, nvidia-prime