Cannot boot up Windows 10 after installing Manjaro

it didnt work

this didnt work too.(sorry dont know how to do multiple reply)

Please, open the console and do the command:

cat /etc/default/grub

and then copy here the output.


GRUB_CMDLINE_LINUX_DEFAULT="quiet splash apparmor=1 security=apparmor udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki:

Now edit again


and remove ‘quiet splash’ like this:

GRUB_CMDLINE_LINUX_DEFAULT=“apparmor=1 security=apparmor udev.log_priority=3”

Update with

sudo update-grub

and reboot.

sorry im not native speaker i didnt understand,are you telling me me to delete the line?,can you show me before and after removing “quiet splash”

No, don’t delete the line! But only the words quiet splash

Now, your grub is:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash apparmor=1 security=apparmor udev.log_priority=3"

After the edit, it would be:

GRUB_CMDLINE_LINUX_DEFAULT="apparmor=1 security=apparmor udev.log_priority=3"
1 Like

ok,there was a menu there for 5 secs,but there was no Windows 10 option in there,only Manjaro

Please open the console:

test -d /sys/firmware/efi && echo efi || echo bios

and post the output.


Your problem is you have installed Manjaro in EFI mode, and Windows is in MBR.
Never mix UEFI with MBR partition scheme.
I think you should reinstall Manjaro in MBR mode

When you install Manjaro, if you don’t want to reinstall Windows, you have to disable EFI in the Bios firmware.

You can this detailed guide:

Good luck. :wink:

Ok thank you,i will try it later.Have nice day

I correct myself: with Win10, via diskpart, it is possible to convert from MBR to EFI without reinstalling windows.
See here:

If you are not practical, you can always use shareware tools that do the job for you.
I think it is more convenient to have both systems in EFI. :slightly_smiling_face:

Ok it seems that i need to remove Manjaro,but how?
I tried to delete it with fdisk on Live Manjaro USB ,but it didn’t work for some reason
Do i need to delete Manjaro partition on Windows Live USB?
Or can i make Windows UEFI without opening Windows?

Indeed, if both are not the same (both EFI or both MBR) grub cannot list the other one.

You re right,but i installed Manjaro as Legacy this time and Manjaro doesnt even boot up this time.Also i deleted Manjaro and there was still no Windows.

Yes, exactly. You mixed up msdos parted BIOS install of Windoze with kind of trial in EFI mode for Manjaro, can’t allow you to boot Windoze via grub menu. Either install both systems in BIOS mode (with msdos or gpt parted disk) or install both in UEFI mode with gpt parted disk.

Why didn’t you follow the idea of changing Windows from MBR to EFI?
Now, I’m afraid you’ll have to restore the Windows boot loader and reinstall Manjaro.

Ok had to reinstall Windows but did it.Thanks for efforts.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.