Cannot Boot Manjaro Live From USB

I recently bought myself a refurbished Lenovo Thinkpad X131e that came pre-installed with Win10. I tried to boot into a live session of the Manjaro-I3 via USB. I got past the live GRUB, but the boot throws the following error that leaves me in prompt mode:

[0.003950] __common_interrupt: 1.55 No irq handler for vector
mount: /run/miso/sfs/livefs: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error.
ERROR; Failed to mount '/dev/loop0'
      Falling back to interactive prompt
      You can try to fix the problem manually, log out when you are finished
sh: can't access tty; job control turned off
[rootfs]#

I figured it might be something to do with Windows, so I tried booting into a session of Gparted Live. That went fine: although a similar error to the first line of the above did flash briefly. I erased all existing partitions and created new ones in preparation for Manjaro. I then tried booting into Manjaro again, but to no avail.

Yes, Secure Boot is disabled. The only other thing I changed was the boot priority. It was set to Legacy initially. So I changed it to UEFI. Same result.

Extend the boot parameters by

acpi=noirq

You probably have a corrupted download.

  • Check the SHA1 hash of your download
  • If different or no clue what I’m talking about :grin: : download and burn again
  • if OK,
    • try another USB stick
      OR
    • please take the XFCE or KDE version and try again and report back.

:+1:

1 Like

Had no effect.

Did both. Double checked the iso’s manually and automatically. No effect.

This also seems to a problem for some Arch users. From what I can tell, it’s a harmless error message that the computer interprets as an emergency and worth interrupting the boot for; something to do with the BIOS and particularly those running off AMD processors. The OP posted a work around that essentially demotes the “urgency level” of the error message, but I’m not sure how to access to do that from his description. In the meantime, I’m gonna try installing a different distro to see if I get the same result.

Actually download an older version and install kernel 5.4 LTS instead of whatever the older version comes with.

Then once 5.9 gets released (it’s in RC now) try that as that patch should be included in there and if not, wait until 5.10 gets released before trying again…

You were right. I just tried running an live session of Mint and it booted fine; though that “No irq handler…” error still flashed. The previous release of i3 booted up without a hitch. Installing now.

1 Like