Cannot boot live USB with "failed to mount /dev/loop" error

I’ve successfully run Manjaro in dual boot with Windows 10 on my laptop for a year now. But I wanted to reinstall both of my systems. I’m already done with Windows which, by the way, I updated to Windows 11. The whole process left my Manjaro partitions intact and working fine.

However, I’m having troubles with booting Manjaro KDE from USB in order to reinstall it. I’ve tried 21.3.7, 21.3.6 and 21.2.2 (the last one is the one I have currently installed). I’ve tried making live USB on Linux using dd and on Windows using Rufus. I’ve tried running it with community and proprietary drivers. But every single time I get the “failed to mount /dev/loop” error when I try to run the system from USB. I think it’s strange since I’ve already installed multiple versions of Manjaro on the very same laptop using the very same USB stick and I had no troubles at all. The only thing changed is the Windows version. Can this be the problem? Or can I fix it somehow else?

  1. try using ventoy instead of dd or rufus or whatever …
  2. why reinstall at all when, as you say, your installation is intact?
    It is a rolling release - you are always at the newest if you update your system.

All you probably have to do is reinstall grub as the windows install process likely wiped it out.

I don’t think grub got wiped out since it looks ok while booting. And I wanted to reinstall it just to have it clear as new. Ok, I’ll try ventoy and see if it helps