Cannot boot into Manjaro need to load kernel first (encrypted disk)

Upon boot I get the error:

error: file '/boot/vmlinuz-5.10-x86_64' not found
error: you need to load the kernel first

Press any key to continue...

Pressing another key does nothing to help the situation. My computer froze during an upgrade. Is there anything I can do to salvage it? I can go to grub or run memtest86+

please help. This is an encrypted drive as well, although the decryption works fine, wouldnt this make using a live usb impossible to help the situation? I think I need some help from someone who knows grub

This won’t ever help with anything in Linux that I’m aware of.

Yup. Chroot in and finish the upgrade.

1 Like

can you be more specific, like give me specific steps? Sorry I never used chroot before. Does it matter that my drive is encrypted?

I apologize, that’s as simple as i can make it for you. We’ll have to wait for someone willing to go more in depth than i have time for.

I would suggest checking out the Manjaro wiki and even just googling how to chroot Manjaro. You’ll find it’s a pretty covered topic.

1 Like

Do you have a live usb with a recent version of Manjaro? You need to boot with the live usb and then try and use chroot into your system to finish the upgrade if you can. There’s a few tutorials on how to use it

https://wiki.manjaro.org/index.php?title=GRUB/Restore_the_GRUB_Bootloader

1 Like

I can make a new Manjaro live USB no problem.

The issue that I’m concerned with is that since my hard drive is encrypted, wouldnt I not be able to read my hard drive from the LiveUSB? Obviously I know the password to decrypt it, but I have no idea how to access an encrypted drive via a liveusb setting

Have to be honest I don’t know much about chroot with encryption but I did find this in the archived forum

1 Like

I’m going to try and follow that in a few minutes.

I do have some good news though, with my manjaro liveusb, I was able to decrypt my hard drive and recover my files at the very least.

One thing I did was, look into the path ‘/boot/vmlinuz-5.10-x86_64’

The file absolutely exists. It is also not an empty file. I don’t understand why it wouldnt just work?

1 Like

I am trying to follow the guide with “How to chroot into an encrypted root partition”

The only issue is that there are a few little differences between his filesystem and mine. Understanding boot partitions and such is something I never really totally understood in linux and I am wondering if someone can look at my lsblk output and perhaps close the gap? Which of these is my boot partition?

NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINTS
loop0                                           7:0    0    26M  1 loop  /run/miso/sfs/livefs
loop1                                           7:1    0 389.9M  1 loop  /run/miso/sfs/mhwdfs
loop2                                           7:2    0   1.1G  1 loop  /run/miso/sfs/desktopfs
loop3                                           7:3    0 731.7M  1 loop  /run/miso/sfs/rootfs
sda                                             8:0    0 119.2G  0 disk  
├─sda1                                          8:1    0 110.4G  0 part  
│ └─luks-c518f431-5efe-4155-b66a-e9c0cae948a6 254:0    0 110.4G  0 crypt /run/media/manjaro/cadacf71-28d3-44d1-902d-80c3deb74fb8
└─sda2                                          8:2    0   8.8G  0 part  
  └─luks-acc2bc57-fc20-4090-a07f-27b854ca61ce 254:1    0   8.8G  0 crypt 
sdb                                             8:16   1  57.3G  0 disk  /run/miso/bootmnt
├─sdb1                                          8:17   1   2.3G  0 part  
└─sdb2                                          8:18   1     4M  0 part  
sr0                                            11:0    1  1024M  0 rom   

Ok… Not trying to be spammy here. Sorry if I come off that way. However I have figured out how to chroot into my encrypted drive using df. It was mounted at /dev/dm-0

the only issue I’m running into now is… when I chroot into my drive, I do

sudo pacman -Syu

and it says there is nothing to do. That means the upgrade went through. What else could it be?

I got it.

The solution is a combination of things posted here.

It doesnt matter if the drive is encrypted or not. Just mount it as normal, I just used Dolphin (from KDE), I clicked it, and it asked for a password. This mounted it in two locations. One which was sda1 (I think) was the encrypted version

then I did df to get the device location for the unencrypted version (which was something like/dev/dm-0), and mounted it to /mnt

then I used manjaro-chroot

manjaro-chroot /mnt

then I found some command that honestly made me a little worried because I never saw a pacman command look this complicated, but it did work, and all it did was reinstall the current kernel

  • From the # prompt, type this to reinstall your kernels:
sudo pacman -Syu $(pacman -Qq | grep -i "^linux[0-9]")`

(all this does is query your current packages, and finds the one that matches the kernel package name and installs it)

then I booted. I then typed the wrong password to decrypt my harddrive, and thought I messed something up lol. But once I tried it again, it worked.

1 Like

Great news you got it fixed :+1: :grinning:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.