Cannot boot into Manjaro after update

The update worked for all but some 40 AUR packages. I assumed they are not system relevant and didn’t try anymore. After the reboot I’m getting the same error as in the original post :confused:

Does it make sense to try to run lightdm from the tty? I tried and it gives me a strange error about not being able to import metadata package for optimus-manager, although I’ve checked I’m using prime.

I would like to see the output of

pacman -Qs optimus
pacman -Qs nvidia
pacman -Qs vala

EDIT - you mentioned it … optimus manager. Knew it.
So … do you really need it ? Do you realize it is an AUR package that needs to be rebuilt?

IF you need it … you need to rebuild it against your current libraries, as you would with other AUR packages.

But thats if … most who use optimus manager actually have no reason to.
I would suggest removing it altogether … but one way or the other, it is likely the source of your issue.

See here:

I would think I don’t need it because I have prime installed. Now I assume that lightdm is somehow configured to use optmus-manager, that’s why I cannot load it? How do I make it use prime?

thanks, looking into it now.

OM uses prime too … its just a hacky layer for forcing one or the other GPU to be disabled between boots … its hybrid mode is functionally the same as OM missing - it just invokes PRIME as it works already.

See the other thread for removal instructions.

Thanks, that did it :partying_face: still receive a list of “scary” messages when booting (now more than in the original post) but at least I can work on them from XFCE, which is much more comfortable.

Yay … for the moment :wink:

We probably need to get you to a working/fully-synced situation … I am not sure the vala thing is resolved, and you probably need to attend to the AUR updates/rebuilds … and then theres the possibility that you have had some things pulled from the AUR that shouldnt be.

Maybe start with:

sudo pacman-mirrors -f && sudo pacman -Syyu

and make sure no errors.

Thanks!
I now update the AUR packages one by one. The vala thing… I removed vala :sunglasses: so it shouldn’t cause any problems anymore.
sudo pacman -Syyu is now clean.

Great, now the AUR.
I personally dont use pamac … but assuming it is the only AUR helper you have installed:

pamac update --aur --devel

Good point, because pamac wasn’t doing it, I just ran yay.

Then, directly after a system update, I would do:

yay -Sua --devel

( rather a full system update looks like   sudo pacman -Syu && yay -Sua --devel )

…but I guess that means you are all good then?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.