Cannot Boot from ISO - Stuck on Recovering Journal

Hey gang,
After an attempt at updating my video drivers (big mistake apparently), I am not stuck on “recovering journal, clean, 359016/15613952 files, 6753986/62435619 blocks”

Following a lot of searches here, I created a bootable ISO with Rufus (manjaro-xfce-21.3.4-220718-linux515). That process complained about it being a hybrid and forced it to mode DD.

With the usb drive inserted into my MinisForum UM700, it flashes the MinisForum logo, then goes straight to black screen with recovering journal.
I have tried holding down F8 while booting. The recovering journal disappears for a sec, then comes back.
(Also tried F1 and F2 just in case).
There seems to be no i/o option whatsoever.

I’m scared that I’ve fubared my brand new machine.

I am extremely new to linux but well-versed in Windows. At this point I don’t care if I have to wipe what’s on the box and start over…I just want a clean install.

so can you enter tty, boot normally and in the stuck screen press: ctrl+alt+f2 or f1-f6 keys instead of f2, and enter your username password … then run this:
mhwd -li and write what drivers you have installed

1 Like

Ahhhh I figured out my problem - I was using a bluetooth keyboard. I realized at that point the bluetooth driver wasn’t even alive yet. Switched to a wired keyboard, then followed instructions on another post to uninstall video-vesa and video-modesetting.


Thank you!!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.