Cannot Adjust Brightness In Lenovo Laptop

Hi There !!
It has been weeks since I have faced this issue

ls /sys/class/backlight
amdgpu_bl1 nvidia_0

I run a hybrid graphics card and during installation I didn’t face this issue
I have to manually become superuser and do

echo 30 | tee /sys/class/backlight/amdgpu_bl1/brightness

inorder to set the background of the screen


In arch linux backlight page I saw this issue listed and tried their method but still I was unable to solve this issue…

Anyone who run hybrid amd graphics like me ?
Do you have this issues related to backlight control ?
Since Xbacklight tool doesn’t work on Amd machine, can you suggest me tool for adjusting brightness of my screen ?

Hello,

Where did you got stuck exactly? Instead of using their example with backlight:amdgpu_bl0 you have to use backlight:amdgpu_bl1 as per your output

Everything else is quite straight forward …

1 Like

My concern is that I cannot adjust the brightness of my screen
Before I used to adjust it using a slider whilst in KDE but in i3 I just have one option
Using the shortcut keys i.e default in everyone laptop
Fn + F5 /F6 for brightness up and down
in my configuration file there is no mention of that however I am sure the keyboard binding is adjusting the brightness since there is a pop up shown on the screen showing Level up and down
Same is true for my audio control… My configuration file does not have any audio control mention, however the system adjusts the my audio when I press Fn + F2/F3

Since Xbacklight tool doesn’t work on Amd machine, can you suggest me tool for adjusting brightness of my screen ?


Yeah I have tried that and am certain I did everything they said including placing amdgpu_bl1 instead of amdgpu_bl0 but still the brightness is not being adjusted

I can also assure you that everything were perfectly fine in previous days
Some update broke this and I don’t know which one
So I don’t have any idea to downgrade which package

I see this problem no matter what distro I use… I previously used Arch but recently am using Manjaro
I saw the same issue in Arch and also here in Manjaro… BTW I tested this on also in Endeavour Os and the problem was still there

Just checking. Can you install brightnessctl package and verify if this command works or not → brightnessctl set 100%. Also share your i3 config file.

Here is the i3 config file

brightnessctl set 100%
Updated device ‘nvidia_0’:
Device ‘nvidia_0’ of class ‘backlight’:
Current brightness: 100 (100%)
Max brightness: 100

and if you wanted to know if the brightness increased of decreased… Nothing happened


and I am adjusting the brightness of my laptop using

echo 30 | tee /sys/class/backlight/amdgpu_bl1/brightness

Can you take a look into these Brightness issue seen in a laptop of my company

There I didn’t get what to place in

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"

EndSection

Driver busid identifier for my machine
I don’t know what parameter is set for my Identifier Busid Driver and Option


Edit:
Changing the title since this issue seems to be only in Lenovo Laptop running Linux

According to this issue on the arch forums try adding acpi_backlight=vendor in GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub as root and run sudo update-grub. Reboot for changes to take effect.

Can you also help me understand what is controlling my backlight… brightnessctl is modifying the nvidia_0 file I guess
but modification of nvidia file doesnot change the brightness

ls /sys/class/backlight
amdgpu_bl1 nvidia_0

both amdgpu and nvidia are listed in backlight but
modification of amdgpu_bl1/brightness only changes the brightness of my screen and the most intimidating this is
I have to switch to superuser inorder to control the backlight

I have tried that… not just that I have kept acpi_backlight to all the parameters listed but none of them worked

What about this one video.use_native_backlight=1?

Check if any problem related to brightness is mentioned in the Remarks section for your model:

https://wiki.archlinux.org/title/Laptop/Lenovo

I tested acpi_backlight=video and for now it worked I hadn’t tested this option before
For others or new users
Add acpi_backlight=video in GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub as root and run sudo update-grub. Reboot for changes to take effect.
if that doesnot work try vendor/native
if that does not work either pull a thread

1 Like

I checked but issues like that weren’t mentioned
I have also seen the Arch Forum for this issue but this wasn’t mentioned

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.