Cannot Adjust Brightness in Dell Laptop with AMD CPU + Nvidia GPU

Hey folks! Yet another problem with adjusting screen (and keyboard) brightness. I have a nvidia GPU and amd CPU in my new laptop

inxi -Fy
  Host: lucas-notebook Kernel: 6.1.31-2-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.5 Distro: Manjaro Linux
  Type: Laptop System: Dell product: Dell G15 5525 v: 1.6.1
    serial: <superuser required>
  Mobo: Dell model: 03MJW9 v: A01 serial: <superuser required> UEFI: Dell
    v: 1.6.1 date: 12/15/2022
  ID-1: BAT1 charge: 57.5 Wh (100.0%) condition: 57.5/56.0 Wh (102.6%)
  Info: 6-core model: AMD Ryzen 5 6600H with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 3 MiB
  Speed (MHz): avg: 1499 min/max: 1600/4563 cores: 1: 1600 2: 1367 3: 1600
    4: 1600 5: 1361 6: 1600 7: 1600 8: 1368 9: 1359 10: 1343 11: 1600 12: 1600
  Device-1: NVIDIA GA107BM [GeForce RTX 3050 Mobile] driver: nvidia
    v: 530.41.03
  Device-2: AMD Rembrandt [Radeon 680M] driver: amdgpu v: kernel
  Device-3: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
  Display: wayland server: v: with: Xwayland v: 23.1.1
    compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau dri: radeonsi gpu: nvidia,amdgpu
    resolution: 1536x864
  API: OpenGL v: 4.6 Mesa 23.0.4 renderer: AMD Radeon Graphics (rembrandt
    LLVM 15.0.7 DRM 3.49 6.1.31-2-MANJARO)
  Device-1: NVIDIA driver: snd_hda_intel
  Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_acp6x
  Device-4: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  API: ALSA v: k6.1.31-2-MANJARO status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp3s0 state: down mac: 04:bf:1b:50:70:db
  Device-2: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e
  IF: wlp4s0 state: up mac: bc:f4:d4:3e:31:e5
  Device-1: Foxconn / Hon Hai MediaTek MT7921 Bluetooth driver: btusb type: USB
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 1.82 TiB used: 27.25 GiB (1.5%)
  ID-1: /dev/nvme0n1 vendor: A-Data model: LEGEND 700 size: 1.82 TiB
  ID-1: / size: 1.79 TiB used: 27.25 GiB (1.5%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 308 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 46.2 C mobo: N/A gpu: amdgpu temp: 44.0 C
  Fan Speeds (RPM): N/A
  Processes: 328 Uptime: 11m Memory: available: 30.59 GiB
  used: 4.08 GiB (13.3%) Shell: Zsh inxi: 3.3.27

but I cannot adjust the brightness. I tried several different thins, such as using acpilight, adding the grub parameters GRUB_CMDLINE_LINUX_DEFAULT="quiet splash udev.log_priority=3 acpi_backlight=video" (I tried with vendor as well). If I type ls /sys/class/backlight/ I get nvidia_wmi_ec_backlight.

If I run sudo xbacklight -set 50 (for example), then

>cat /sys/class/backlight/nvidia_wmi_ec_backlight/brightness  
>cat /sys/class/backlight/nvidia_wmi_ec_backlight/actual_brightness

Adn the actual_brightness does not change no matter that I do.

Any tips on what I can do? I’d really love to fix this! I hava manjaro in a intel+nvidia system (from avell) and did not encounter this issue.






sudo update-grub
sudo mkinitcpio -P

and reboot
please report after reboot what’s in

ls /sys/class/backlight

to proceed

1 Like

So, I did that and now I can control the brightness through the terminal and kde button! Thanks! Not through the keyboard though, but I think that is a keyboard issue not with the video anymore. Anyway, as you asked:

>ls /sys/class/backlight
amdgpu_bl0  nvidia_0
1 Like

so everything is okay now. keyboard is a different story.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.