Cannot add printer HP Deskjet 2630

On the latest version of Gnome Manjaro, 20.2. Printer used to work on 20.1 and now cannot be added. The printer is on the same network as the computer, and shows up when searching.

But after clicking add, the "Failed to add printer" error is prompted.

Followed the instruction to change the systemctl. Firewall is disabled, and the printer IP can be pinged.


With a usb hp printer i had the same problem.
Installing the printer with this command:

hp-setup -iax

Solved my problem.
Maybe it could give more information if the problem persist

Thanks for the reply. Using hp-setup -iax and selecting option 1 (net, Network/Ethernet/Wireless (direct connection or JetDirect)), gave the following error

error: No device selected/specified or that supports this functionality.

I get the same error when using the GUI HP app hplip.

Hi liuyun,

I have the same error message in Gnome settings, but with a Brother MFC printer. Have you tried to add your printer through the web interface on localhost:631?

1 Like

Thank you very much hroettgen. Adding the printer through the localhost worked!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.