Cannot access GUI after removing light-dm launcher


I really need some assistance here. I tried to install the lighdm with the theme glorious on my manjaro installation. This failed, but I could still access my system when logging in by choosing the default login.

I the stupidly perhaps, removed the lightdm launcher from the add/remove software interface. What now happens is that I cannot access any interface, only the tty terminal. Is there a way to access the GUI again through the tty terminal, or perhaps start the default launcher or install a new one?

I would like to post a picture of the output, but I do not seem to be able to do it.

I’ve tried removing and installing new graphics drivers after looking around for solutions, but this has not helped.

Any help with this would be really appreciated as I’d rater not re-install.


Hi @erkiman, and welcome!

What happens when you log into the TTY and run:


Hi! Thank you

I get some various output, not sure how to get it all over here. It basically says:

xinit: connection to X server lost.

Waiting for X server to shut down(II) Server terminated successfully (0). Closing log file.



And what happens of you run this instead:



Wow, that actually worked! I’m back in!

Any pointers on how to reverse it so that the basic launcher will start automatically?

Thank you very much!


Try reinstalling lightdm?

Or if you don’t want that, try:

Choose Xfce Session from the menu in a display manager of choice, or add exec startxfce4 to Xinitrc.

Note: Do not call the xfce4-session executable directly; startxfce4 is the correct command which, in turn, calls the former when appropriate.

…according to the Arch Wiki.

How did you do this?

That is, as far as I know, not a needed part of the standars installation - perhaps it is part of an AUR package that you installed to get the theme that you wanted.
Make sure you completely reverse whatever you did - remove any AUR package related to lightdm, for instance.

Then, after a reboot, check the status of the service
systemctl status lightdm.service
and, if needed, start and enable it

Yes, ok. I re-installed light-dm and now I can log in using that one. It looks a bit off graphically, as if there is something wrong with the graaphics driver perhaps but it works.

Thank you so much for the help.


1 Like


Thank you so much for the reply. It seems to be resolved for now. I really appreciate the quick and helpful responses as a beginner.


Since I use neither Xfce nor lightdm (obviously) I can’t help with that, sorry.

You could always make proper backups and customize it then. This way, you can roll back if something breaks.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.