Canberra-gtk-module warning

Hi all,
I am currently finding some warnings while opening Emacs 28.0.50.
Whenever I run it, I get the following error:

$ emacs --debug-init

(process:268759): Gtk-WARNING **: 16:20:06.121: Locale not supported by C library.
	Using the fallback 'C' locale.
Gtk-Message: 16:20:06.297: Failed to load module "canberra-gtk-module"
Gtk-Message: 16:20:06.297: Failed to load module "canberra-gtk-module"

I suspected it was because I was missing the gtk dependency but checking pamac, I noticed I had both lib32-libcanberra and libcanberra installed.

Any idea on how should I proceed further to fix them? I suspect it might contribute to a massive Emacs slowdown I am experiencing.

Thank you in advance for your help!

[inxi -Fazy]

Pretty straight forward.

When you get the above error then you have a problem in your local configuration.

localectl status
1 Like

Here’s the output:

$ localectl status
   System Locale: LANG=en_GB.UTF-8
       VC Keymap: it2
      X11 Layout: it
       X11 Model: pc105
     X11 Variant: winkeys

Have used the troubleshooting from this topic?

Did you actually uncomment en_GB in /etc/locale.gen and build the locale using localegen?

Or a search to see what others have asked?

1 Like

Unfortunately, I already searched the forum and nothing turned out to be useful for my specific case.

I uncommented en_GB`in /etc/locale.gen and ran locale-gen, as per tutorial, but nothing changed and the same error shows up.

Sorry to hear that - but you actually fixed a locale error you didn’t knew you had :slight_smile:

Just a thought - look at the bottom of your locale.gen file - what are the last few uncommented lines - if any?

Sorry for the late reply, work got in the way of my system maintenance :confused:

$ tail /etc/locale.gen
#zh_TW BIG5  
#zu_ZA.UTF-8 UTF-8  
#zu_ZA ISO-8859-1  

# Locales enabled by Calamares
en_US.UTF-8 UTF-8
en_GB.UTF-8 UTF-8
it_IT.UTF-8 UTF-8