Can’t update (PGP Error Invalid or Corrupted Package)

I’m running Manjaro on a Raspberry Pi 4 with 4 gigs of ram and the xfce desktop environment. When I try to download any software I’m greeted with an error reading “(file) is corrupted (invalid or corrupted package (PGP signature).” I’m using Sudo pacman -Syyu if that helps. I’ve tried switching my mirror as well as downloading software with other commands and it hasn’t worked, any thoughts?

I’ve tried all of these now, thanks for your help so far, unfortunately none of them worked, even after directly removing the files from the cache, they’d just reinstall in the next update. However, I did track down all of them came from signatures from “Ray Sherwin” (an unknown trust)

Also, all of the failed upgrades are directly related to raspberry pi

Ray’s gpg key should be in our keyring, so try this:

sudo pacman -S manjaro-arm-keyring
sudo pacman-key --populate manjaro-arm
sudo pacman -Syyu
1 Like

Thanks! This worked well and we are now up and running!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.