Can’t connect to internet

Hello, extremely new to Linux and Manjaro. Tried to install Manjaro on my laptop (not dual booting, it’s the only OS) and I can’t connect to wifi, all I get is “No available connections”

I’ve tried using my phone’s hotspot and tethering but neither have worked. I’m not really sure where to go from here.

Applogies for poor inxi output, had to take pic on phone then copy & paste text, so my phone may have misread somethings.

inxi output:

Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
Desktop: KDE Plasma V: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Manjaro Linux base: Arch Linux

Type: Laptop System: Microsoft product: Surface Laptop
V: 124000000000000000000000D:F B:OC850289 F: U C:09 P:C1 S:01
serial: <superuser required> Chassis: type: 9
«superuser required>
Mobo: Microsoft model: Surface Laptop serial:
«superuser required>
UEFI: Microsoft v: 138.3732.768 date: 04.20.2021

ID-1: BAT1 charge: 17.8 Wh (44.3%) condition: 40.2/45.2 Wh (88.9%)
volts: 7.5 min: 7.6 model: DYN M1005922 type: Li-ion serial: ‹filter>
status: discharging cycles: 188

RAM: total: 7.68 GiB used: 1.45 GiB (18.8%)
RAM Report: permissions: Unable to run dmidecode. Root privileges

Info: dual core model: Intel Core i5-7200U bits: 64 type: MT MCP
smt: enabled arch: Amber/Kaby Lake note: check rev: 9 cache: L1: 128 KiB
L2: 512 KiB 13. 3 MiR
Speed (MHz): avg: 1000 min/max: 400/3100 cores: 1: 1000 2: 1000 3: 1000
4: 1000 bogomips: 21607
Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
therm dts epb ept ept_ad erms est f16c flexpriority flush_\1d fma fpu
fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
intel_pt invpcid invpcid_single lahf_m m mca mce m_clear mmx monitor
movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pcimulqdq pacm
pdpe1gb pebs pge pin pi popcnt pse pse36 pti pts rdrand rdseed rdtscp
rep_good sabg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
syscall tm tm2 tpr_shadow tsc tsc_adjust tsc deadline timer vme vmx vnmi
vpid x2apic ×getbv1 save xsavec xsaveopt xsaves xtopology xtpr

Device-1: Intel HD Graphics 620 vendor: Microsoft driver: 1915 v: kernel
arch: Gen-9.5 ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300
Display: x11 server: X.0rg V: 21.1.4 compositor: kwin_x11 driver: X:
loaded: modesetting alternate: fbdev, vesa gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 2256x1504 s-dpi: 96 s-size: 596x397mm (23.46x15.63" )
s-diag: 716mm (28.19" )
Monitor-1: eDP-1 model: Panasonic WVX14T092N00 serial: «filter>
res: 2256x1504 hz: 60 dpi: 198 size: 290x190mm (11.42x7.48" )
diag: 343mm (13.5" ) modes: 2256x1504
OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 22.1.6
direct render: Yes
Device-1: Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Imaging
Unit driver: ipu3-imgu bus-ID: 00:05.0 chip-ID: 8086:1919 class-ID: 0480
Device-2: Intel CSI-2 Host driver: ipu3-cio2 bus-ID: 00:14.3
chip-ID: 8086: 9d32 class-ID: 0480
Device-3: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel
bus-ID: 00: 1f.3 chip-ID: 8086:9d71 class-ID: 0403
Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
Sound Server-2: JACK v: 1.9.21 running: no
Sound Server-3: PulseAudio v: 16.1 running: yes
Sound Server-4: PipeWire v: 0.3.56 running: yes

Device-1: Marvell 88W8897 [AVATAR] 802.11ac Wireless driver: mwifiex pcie
v: 1.0 pcie: speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 11ab:2b38
class-ID: 0200
WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig

Message: No bluetooth data found.

Message: No logical block device data found.

Message: No RAID data found.

Local Storage: total: 352.21 GiB used: 8.57 GiB (2.4%)
ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 119.24 GiB
speed: 15.8 Gb/s lanes: 2 type: SSD serial: ‹filter> rev: OAMS0102
temp: 34.9 C scheme: GPT
ID-2: /dev/sda type: USB vendor: SanDisk model: USB 3.2Gen1
size: 232.97 GiB type: N/A serial: «filter> rev: 1.00 scheme: MBR
Message: No optical or floppy data found.

ID-1: / size: 116.52 GiB used: 8.57 GiB (7.4%) fs: ext4 dev: /dev/nvme0n1p2
label: N/A uuid: c982f334-99a6-499f-b293-ac3a5aa9cf52
ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat
dev: /dev/nvme0n1p1 label: NO_LABEL uuid: 9E9C-5C67

Alert: No swap data was found.

ID-1: /dev/sda1 size: 3.32 GiB fs: is09660
ID-2: /dev/sda2 size: 4 MiB fs: vfat label: MISO_EFI uuid: C80E-8B3F

Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900

Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
chip-ID: 1d6b: 0003 class-ID: 0900
Device-1: 2-1:2 info: SanDisk Ultra type: Mass Storage
driver: usb-storage interfaces: 1 rev: 3.2 speed: 5 Gb/s power: 896mA
chip-ID: 0781:5581 class-ID: 0806 serial: <filter>

System Temperatures: cpu: 42.0 C pch: 32.5 C mobo: N/A
Fan Speeds (RPM): N/A

Processes: 169 Uptime: 13m wakeups: 6 Init: systemd v: 251
default: graphical Compilers: gec: 12.1.1 clang: 14.0.6 Packages:
pacman: 1171 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.20

check the software-manager for “linux-firmware-marvell” and install it

Requires the installation of the linux-firmware-marvell package for the wireless network interface to be recognized by the kernel.

Since September 2018, Surface Book 2 WiFi may power off during use. When this happens, it is not visible with lspci and rebooting is a way to get it back on. However, this behavior can be prevented (temporarily) by installing iw and running the following command as root:

# iw dev wlp1s0 set power_save off

To permanently fix the issue with NetworkManager, add this to your NetworkManager config. (Such as /etc/NetworkManager/NetworkManager.conf)

wifi.powersave = 2

When I issue the command:

pamac install linux-firmware-marvell

all I get in return is:

Error: target not found: linux-firmware-marvell

Am I typing it out wrong? Putting sudo before pamac gets me the same output as well.

You typed it right but if you have no internet connection it’s not going to install it.Do you have a way to set up a wired connection to install it.

I tried tethering with my phone and that didn’t work. Unfortunately my laptop doesn’t have an ethernet port either. As far as I’m aware I have no way to connect to the internet.

This is unusual - I do not know the procedure for IPhones but I do know that (and how) all Android devices can do this.

anyway - get a hold of the file
download it to your phone, for example
then transfer it via USB to your device
and use
sudo pacman -U ... to install it

you also want to get

Arch Linux - linux-firmware-whence 20220815.8413c63-1 (any)

in addition to

Arch Linux - linux-firmware-marvell 20220815.8413c63-1 (any)

I do not know where to get these - look at the Manjaro mirrors.

since I did look for the mirrors, I might as well copy/paste the locations of the files on one of them

After shutting my laptop down and letting it sit for an hour, I turned it on and connecting my phone via USB seems to work now. Unfortunately it’s recognizing my phone as a camera, and any posts online say I need a particular package to transfer files while using Manjaro. When I’m back at school tomorrow I will load these two packages on my flash drive via my desktop and post my results. Thank you!

While that is unusual:
what normally happens is that
as soon as you connect your phone
a message will appear (on the phones screen)
telling you the mode in which it is operating
and also letting you choose some other options, such as “charging only” and “file transfer” and one or two others
select “file transfer” (or however it is called) on the phones menu and the mode will change.

But your strategy using an USB flash drive will also work.

This did it for me. Thank you very much!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.