Can´t access AUR using manjaro GUI

Hey there. I just installed kde manjaro and love that, but I can’t access to AUR from app center. I tried the three dot in the corner, Aur is checked, but no apps.I tried from command line and I got the error 429 stuff - but I don´t use VPN.
I saw in the forum I have to wait for a day or two. Am I the only one with this trouble?
Thanks y’all :slight_smile:

What version of Manjaro did you install (edition and version number of the ISO)?

And did you update and reboot before attempting this?

I installed the 64bit KDE 1.4-210927 (the last one in the site).
Yes I dit update then reboot.

Enabling AUR is not strictly necessary as you can use the command line version without any activation.

pamac search --aur <criteria>

The 429 is a standard http message

429 Too Many Requests

If you are getting this is because your system is rejected by AUR - usually because there is too many nested dependencies on a package or to many repeated requests from your IP address - so suspecting the cause could be VPN is valid - but if you still get the rejection you just have to wait until your IP is released from the block list.

I don’t know about that

I have been using Arch and Arch based distributions for many years and I have never encountered the issue.

I just heard about it a couple of months ago when a topic was opened by an Arch maintainer at the pamac repo. It appears Pamac is abusing the AUR search function which then blocks further requests from the public IP address.

Disable checking AUR for updates

The official Arch explanation why the rate limit was introduced is explained in a forum topic from 2020-03-29T21:02:00Z

Incidentally, the rate limit was introduced specifically in order to block users who had, until then, been using conky scripts to check out of date packages at a rate of one API request per package…

… which ran in a tight loop, sending a new batch (of dozens of requests) once per 5 seconds, or however fast the previous “cower -u” succeeded.

Any decent AUR helper capable of checking for updates (that is, not cower) should only send one API request to check many packages at once, so if you check for updates once every 5 minutes you will still only use 288 API requests per day. You’d have to be checking for updates once every 20 seconds to hit the rate limiting at 4320 requests, one request per check (which means you’d run out less than 2 hours before the end of the day).

It is extremely easy to avoid getting rate limited. Even manages to do okay, and they scrape for all metadata for 60k packages by batching as many packages as can fit into one API request (a few hundred), and only scraping once every few hours.
AUR Rate limit reached / AUR Issues, Discussion & PKGBUILD Requests / Arch Linux Forums

As quoted from below the only solution is to stop the requests which will release your IP at some point. This will only get worse if you are using a shared IP or VPN.

No. The solution is to wait until the AUR unblocks you.

A hint could be included in the response-header - something like

Retry-After: 3600

Till then, you can install yay or paru from the AUR.

Here are the commands to install paru.

sudo pacman -S --needed base-devel git
git clone
makepkg -si

That will not solve the issue - as the AUR blocking is based on IP address and not based on user-agent.

1 Like

I did not know that. I thought it only blocked pamac. Should I delete my comment?

No - just leave it - otherwise my comment is misplaced :slight_smile:

I tried that today and it does not work yet… Maybe later…