Can suspend and wake up once but not after that on KDE after recent upgrade

After the most recent upgrade, my Plasma desktop can be made to sleep by typing systemctl suspend and wake up by mouse movement, but only once. After that, sleep does not work.

The sleep icon does not work either; hence the use of systemctl suspend above.

inxi -Fazy gives:

  Kernel: 6.9.3-3-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
    clocksource: hpet avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.9-x86_64
    root=UUID=ba28cd4a-6822-4ccf-a976-423ae8f6620e rw quiet splash
  Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME A320M-K v: Rev X.0x
    serial: <superuser required> part-nu: SKU uuid: <superuser required>
    UEFI: American Megatrends v: 5409 date: 01/07/2020
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter>
    charge: 55% (should be ignored) rechargeable: yes status: discharging
  Info: model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64 type: MCP
    arch: Zen/Zen+ note: check gen: 1 level: v3 note: check built: 2019
    process: GF 12nm family: 0x17 (23) model-id: 0x18 (24) stepping: 1
    microcode: 0x8108109
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
    desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
    desc: 1x4 MiB
  Speed (MHz): avg: 1657 high: 2935 min/max: 1400/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1231 2: 1231
    3: 2935 4: 1231 bogomips: 28757
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT disabled
  Type: spec_rstack_overflow mitigation: SMT disabled
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines; IBPB: conditional; STIBP:
    disabled; RSB filling; PBRSB-eIBRS: Not affected; BHI: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports:
    active: HDMI-A-1 empty: DP-1 bus-ID: 07:00.0 chip-ID: 1002:15d8
    class-ID: 0300 temp: 43.0 C
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93") monitors: <missing: xrandr>
  Monitor-1: HDMI-A-1 model: BenQ GW2780 serial: <filter> built: 2020
    res: 1920x1080 dpi: 82 gamma: 1.2 size: 598x336mm (23.54x13.23")
    diag: 686mm (27") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Vega 8 Graphics (radeonsi
    raven LLVM 17.0.6 DRM 3.57 6.9.3-3-MANJARO) device-ID: 1002:15d8
    memory: 1.95 GiB unified: no
  API: Vulkan v: 1.3.279 layers: N/A device: 0 type: integrated-gpu name: AMD
    Radeon Vega 8 Graphics (RADV RAVEN) driver: mesa radv v: 24.0.9-manjaro1.1
    device-ID: 1002:15d8 surfaces: xcb,xlib
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio
    vendor: ASUSTeK PRIME B450M-A driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 07:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: ASUSTeK PRIME B450M-A
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 07:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.9.3-3-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK RTL8111H driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: TP-Link AC600 wireless Realtek RTL8811AU [Archer T2U Nano]
    driver: rtl88XXau type: USB rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0
    bus-ID: 3-2:2 chip-ID: 2357:011e class-ID: 0000 serial: <filter>
  IF: wlp7s0f3u2 state: down mac: <filter>
  Info: services: NetworkManager, systemd-networkd, systemd-timesyncd,
  Device-1: TP-Link UB500 Adapter driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-3:3 chip-ID: 2357:0604
    class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter> status:
    discoverable: no active: no pairing: yes class-ID: 6c0104
  Local Storage: total: 344.68 GiB used: 255.91 GiB (74.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WDS120G2G0A-00JH30 size: 111.8 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 0000
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: WDC WDS250G2B0A
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 90WD scheme: GPT
  ID-1: / raw-size: 51.75 GiB size: 50.64 GiB (97.84%) used: 40.06 GiB (79.1%)
    fs: ext4 dev: /dev/sda3 maj-min: 8:3
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 116.44 GiB size: 114.06 GiB (97.95%)
    used: 72.74 GiB (63.8%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 8 GiB used: 2.61 GiB (32.6%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2
  System Temperatures: cpu: 42.9 C mobo: N/A gpu: amdgpu temp: 42.0 C
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB note: est. available: 13.58 GiB used: 8.71 GiB (64.1%)
  Processes: 273 Power: uptime: 6h 41m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 5.42 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 1883 libs: 376 tools: pamac,trizen pm: flatpak
    pkgs: 0 Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: Bash v: 5.2.26
    running-in: yakuake inxi: 3.3.34

I am happy to provide more information if it will lead to reversion to the behaviour before the upgrade, when the sleep icon used to work, and could also be used several times in succession without loss of function.

1 Like

Have you tried this with the 6.6 or 6.1 LTS kernels?

Yes. I have tried this with these three kernels:
(a) 6.1.92-1;
(b) 6.6.32-1; and
(c) 6.1.92-1,
with the same results.

In all three cases, I can use either the sleep icon or systemctl suspend to put the machine to sleep. The power LED keeps blinking. On mouse movement, the power LED becomes steady and the machine wakes up.

But I cannot put it to sleep again. If I try, the screen goes black/blank and the machine is unresponsive. Only by switching the machine off manually (holding power button on for forced shutdown), and then cold restarting it, can I regain control of it.

It is relevant that both my keyboard and mouse are Bluetooth connected via a single USB dongle.

My SystemSettings for Energy Saving are as in the attached screenshot.

If something needs to be changed here, kindly let me know.

You could well be right with that one.

I recently discovered that one of my machines refused to sleep with a PS/2 keyboard connected (it’s also a splitter so a mouse can be connected as well). Although if I unplug the KB immediately after hitting the sleep button, it does sleep, even with the adapter still plugged in.

Maybe try a different KB if you have one (preferably without all the media buttons mine has).


pamac remove rtl88xxau-aircrack-dkms-git

pamac build rtl8812au-openhd-dkms-git

Restored WiFi access as well as allowed sleep/wake to happen multiple times.

Long answer: I followed up on the lead of BG405 and looked for the solution among WiFi and Bluetooth.

I have a TP-Link Nano Ac600 USB Wi-Fi Adapter(Archer T2U Nano)- 2.4G/5G Dual Band Wireless Network Adapter for WiFi on my desktop. It was using the rtl88xxau-aircrack-dkms-git driver from AUR. But that driver had stopped working recently.

On replacing it with rtl8812au-openhd-dkms-git, not only was WiFi restored but the machine could sleep and wake up several times in succession.

The suggestion for this came from AUR (en) - rtl8812au-openhd-dkms-git with this comment:

dandyislion commented on 2024-05-04 09:54 (UTC)

Compiles and works great with my RTL8812AU/8821AU on LTS 6.6.30. Works when waking up from sleep too. Thank you for this!

I can confirm that it works with the 6.9.3-3-MANJARO kernel as well.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.