Can not reinstall on Late 2009 iMac

I previously had Manjaro running on this computer (iMac 21.5 inch late 2009). I just replaced the hard drive with an SSD and now I am attempting to reinstall Manjaro. I am now running into problems getting it to work. I remember when I tried to install it previously, I had issues, but I did not document how I got around it. Now I can’t figure out how to get it to install. I am only wanting to run Manjaro, OSX is gone.

I have the latest iso on a thumb drive. When I try installing the latest Manjaro with KDE, I run into one of two problems getting to the installer.

Using the default selections, it boots up into the live Manjaro but with the screen divided up into 4 equal squares each showing the same desktop. The screen is distorted and I can make my way to the menu button to restart, but its difficult to read. Each little square shows the same display as I move the mouse around and click. Its not usable for installing.

Choosing the non free display drivers, it gets up to the line in the boot up process that says:

[OK] Finished TLP system starup/shutdown.

It then hangs on that and I can not proceed.

I was able to try an Xubuntu Live image to get to their installer with no problem. Although once it installed and I rebooted I was presented with the 4 squares again (even though I told it to install proprietary drivers).

I stepped my way through Manjaro architect, but after it finished installing, but it didn’t work for me either. I can’t remember whether it hung at the same place in the boot up or it showed the 4 squares once it was installed.

Thanks for any help

Jason

BUMP please

There are several archived topics with said tlp output:
https://archived.forum.manjaro.org/search?q=Finished%20TLP%20system%20startup%2Fshutdown
Maybe you’ll find a solution there…

Make sure you have a look here
https://wiki.archlinux.org/index.php/IMac_Aluminum

While is fine to point to old forum, for that particular issue

While in the Grub Menu of Live media, press e to edit it, and append after quiet this line
systemd.mask=tlp.service
Then press F10 to save and continue booting.