Can not install pi-fancontrol using snap

I am using Manjaro ARM Xfce on raspberry pi 4B
I have build fan circuit with transistor what worked very well on Raspbian.
Now i would like to use this solution in Manjaro.
That is why I am trying to install pi-fancontrol using snap.
Installation process is from this site:

I have an issue with installation:

sudo snap install pi-fancontrol

error: cannot perform the following tasks:
– Run install hook of “pi-fancontrol” snap if present (run hook “install”: /usr/lib/snapd/snap-exec: /lib/aarch64-linux-gnu/ version `GLIBC_2.32′ not found (required by /usr/lib/snapd/snap-exec))

For the reference i have tried to install:

sudo snap install marsshooter

what is wierd - the installation process seems to be OK but I con not run the application because of error while executing:

/usr/lib/snapd/snap-exec: /lib/aarch64-linux-gnu/ version `GLIBC_2.32’ not found (required by /usr/lib/snapd/snap-exec)

System is up to date with pacman -Syyu

Could anybody help me please?

What version of snapd do you have installed?
pacman -Qi snapd will tell you.

It’s odd. It complains about glibc 2.32. But 2.32 is present in all our branches. So it should be able to find it.

My version of snapd is;

Name : snapd
Version : 2.49-1
Description : Service and tools for management of snap packages.
Architecture : aarch64
URL : GitHub - snapcore/snapd: The snapd and snap tools enable systems to work with .snap files.
Licenses : GPL3
Groups : None
Provides : None
Depends On : squashfs-tools libseccomp libsystemd apparmor
Optional Deps : bash-completion: bash completion support
xdg-desktop-portal: desktop integration
Required By : None
Optional For : None
Conflicts With : snap-confine
Replaces : None
Installed Size : 59.43 MiB
Packager : Dan Johansen
Build Date : Thu 11 Feb 2021 11:38:11 AM CET
Install Date : Tue 16 Mar 2021 08:13:16 PM CET
Install Reason : Explicitly installed
Install Script : Yes
Validated By : Signature