Can not change the time anymore

When I change the time it says “time can not be changed” after I type the password. That was not the case before. I always had to change the time because I did not do the “hack” yet that keeps the time as it is in the bios.

The PW is correct cuz I just did updates just fine.

Anyone know what thats all about?

I also wonder why a simple time change needs a pw in the first place. It is overkill!

Operating System: Manjaro Linux
KDE Plasma Version: 5.26.5
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8
Kernel Version: 5.15.94-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-9700K CPU @ 3.60GHz
Memory: 15,6 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2080/PCIe/SSE2
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: Z390 AORUS PRO

How are you changing it and why and how often?

rightklick on the time, adjust date and time

I dont know what the “how often” has to do with anything but once when I start manj because it always shows the wrong time.

It keeps running 1 hour ahead when I start Manj.

Nevermind, I found it. I hope the time stays correct now.

Solution: timedatectl set-local-rtc 1 --adjust-system-clock

So you also run windows?

Maybe, either way it’s advised not to do this. The system time should be set as UTC not localtime.

The proper solution is to configure windows so it uses UTC like it should. You’ll also have to reverse the command you ran.

# run on windows
reg add "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TimeZoneInformation" /v RealTimeIsUniversal /d 1 /t REG_DWORD /f

# run on linux
timedatectl set-local-rtc 0 --adjust-system-clock

1 Like

I set Windows to use UTC to not have the wrong time in Kubuntu after running Win and everytime I booted into Win after Kub it added another hour in Win, so I used the command mentioned above in Kub too to avoid that. I forgot about it because it was a year ago but I actually still have the link in Kubuntu.

But now I am just switching between Kubuntu and Manjaro and the problem arose in Manjaro.

I just want my system to use the bios time without the need for it to search the time online. Getting the time online is unneccessary and I disabled that in Win over a decade ago already and in Kub and Manj when I installed it.

Why the time cant be changed the way I did is still annoying me though. It feels like the system is patronizing me when I dont let it get the time online. Although it worked for months to change the time so I have to assume some patch messed something up.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.