Can not boot my computer

I just tried shutting down my computer but it was stuck on the screen that shows the DELL logo. I unplugged my PC and then later in the day tried to turn my PC on again. But now I can not boot in. It shows the same screen (Dell Logo) and stays there. One time it showed a screen with failed to start pkgfile database update error, but now it does not shows anything and stays on the logo screen.

What is the model of the Dell, how old is it?

It’s a Dell Optiplex 7040 Micro (i3 6th gen, 8GB DDR4, 256GB SSD), I got it renewed from amazon and installed Manjaro in it.

The Dell logo is before the OS is started, during the bios part of the boot up. You might try clearing the bios to see if it helps. Unplug the machine, remove the coin battery and press the power button. Wait 5-10 minutes then put the coin battery back in, and power plug. Then try starting the computer.
You will likely get a warning, if an option is there to load defaults, do that.

I have tried that, but I think that there is some problem with my manjaro installation as I tried uninstalling (I forced removed it) and reinstalling package as it was interfering with my nodejs installation.
Is there any way to repair my installation? I don’t want to reinstall manjaro because I don’t want to lose my documents and the customizations that I made.

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )

You can also use Maxi

to collect information about the boot process. This works,

  • when you are in your running system (with CTRL+ALT+F2).
  • And also in a live environment

Those guides should give you some basics.

you need to chroot, and repair your installation - libicui18n - from there…
so boot into live usb of manjaro, connect to internet, chroot:
manjaro-chroot -a
(this command doesnt work with btrfs and encryption, you have to chroot manually);
then rerun update:
pacman-mirrors --fasttrack 5 && pacman -Syyu
post any errors from this here;
reinstall the libicui:
pacman -S icu lib32-icu
post errors here…
if there were no errors, exit chroot:
reboot and see if it helped

I tried doing what you have mentioned, and now when I restarted I got pas the dell logo and then a black screen, nothing happened. I tried the shortcut (ctrl alt f4) to get to the tty screen. Then I log in using my user and then after login it displays -

flatpak: error while loading shared libraries: cannot open shared object file: No such file or directory

What should I do now?
I can reinstall manjaro but is there any way to save the previous customizations and documents?

were there any errors when you were in chroot running the commands?
try using overwrite command from tty: ctrl+alt+f2
sudo pacman -S icu lib32-icu --overwrite '*'
if no errors reboot

Yes, There were some errors.
When I execute the manjaro-chroot -a in live environment, this error was displayed -

grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your

 grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your

 ==> Mounting (ManjaroLinux) [/dev/sda2]

 --> mount: [/mnt]

 --> mount: [/mnt/boot/efi]

Those are normal, they are related to the usb… Continue with the overwrite command

I tried the overwrite command and it did its thing. But I am still unable to boot. I can see the manjaro logo and the dell logo flickers 3 times now. But still not booting to the desktop environment.

From tty rerun update again:
sudo pacman -Syu
Are there any errors? Its possible that more things got messed up when you were messing with the icu …