Can not boot into manjaro & Grub not showing

Hi there.
I am not new to Manjaro.

I am dual booting next to Windows.
As my root partition got too small i decided on performing a reinstall with only a root partition (in contrast to having separate root and home partitions).

Before reinstalling i also decreased the Windows partition to make more space for Manjaro.

As part of the reinstall i deleted all previous Manjaro partitions (boot, swap, root, home) and created new ones (boot, swap, root). The reason i also deleted boot is because with the reduced windows partition all the other partitions are now in different locations and i figured it would create problems if i left the old boot partition.
Manjaro installed just fine from the live USB.

The problem now is that Grub does not show up anymore and the system directly boots into Windows.
In my Bios i can choose the boot order and Manjaro is even listed as first entry. But even directly booting into Manjaro is not possible.
Secure Boot is disabled.

I figure the entry in the boot menu is from the previous install and does not work anymore.

I am also too inexperienced to try and mess with the Bios other than changing boot order or enabling/disabling secure boot…

Device: Thinkpad X1 Yoga 4

Thank you for any suggestions/help!

When booting from the live USB there is the option “Detect EFI Bootloaders”.
Running this gives me the following list:

  • (hd0,gpt5)/efi/Manjaro/grubx64.efi
  • (hd0,gpt5)/efi/boot/bootx64.efi
  • (hd0,gpt1)/efi/Boot/bootx64.efi
  • (hd0,gpt1)/efi/Microsoft/Boot/bootmgr.efi
  • (hd0,gpt1)/efi/Microsoft/Boot/memtest.efi
  • (hd0,gpt1)/efi/Microsoft/Boot/bootmgfw.efi

where gpt1 is the boot partition of Windows and gpt5 the one of Manjaro.

Choosing either the first or the second yields the output:
error: not a valid root device.

Tanks for the quick answer.
I believe you want me to fix the os prober problem?

Manualy add the line GRUB_DISABLE_OS_PROBER=false to /etc/default/grub
Run sudo update-grub

Where do i run the update-grub command? Also from the live USB?

I was too fast, I didn’t read that your issue is different than most other grub problems today. In your case best solution should be chroot (on Wiki was pretty article about restoring grub with chroot, but currently is down).

Now that the wiki is upagain, i followed this guide.

Unfortunately the situation has not changed. Still cannot boot into the system, neither from the BIOS nor from the live USB.

Found the solution here.

The problem was the boot partition having the wrong flag. I am pretty sure that i chose the correct flag during the installation. Could this be a bug?

Thank you @Tomek for your help. Even if it was a different problem in the end :wink:

This helped me fin my other OS on the same drive but different partition.
Saved me from a lot of extra work.

Thank You.

Thank you.
Unfortunately i cannot test this as in the meantime I have reinstalled manjaro but this time the gnome edition (dont know if this makes a difference). Everything worked out of the box including grub and even the windows boot option shows up in grub again. So maybe there is a problem with the manjaro KDE installer?