Can not boot into manjaro after dual booting another os

So i installed another linux distro into another my hardrive, i did update-grub from manjaro, it was working for first few boots, i mean booting into manjaro, but after i wrote some files into the manjaro partition from the other distro, when i restart my pc, it wont boot and show this screen that it cant load kernel and etc.

What did you do exactly ?

I installed pop os on my hardrive, and update-grub from manjaro installed on my ssd, i booted in pop os and copy some files to my ssd home folder where manjaro was installed. After that restarted my pc and now stuck here while booting into manjaro

And I wanted to know what you copied and how.
For example … if you used sudo into your home folder you could have broken permissions.
But I suppose if its to home it shouldnt break early booting to the DM.

You can start here:

1 Like

Yes i used sudo to copy some files, it was a github repo folder actually. Btw thanks for helping i will try this tomorrow morning :blush:, as it is midnight here in India. Good night :sleeping:

Hii nothing worked, i tried booting with the lts kernel same output. I tried cross checking the UUID from fstab and blkid, Nothing has changed.
I am currently using manjaro-chroot from live usb to access the manjaro system.
i can also access the tty terminal. But i am not sure what to do exactly.

Below is the pic of booting with the lts kernel. There is another msg showing this time.

I have also gathered some information about my system using this post

This is the output:

This is the journalctl boot log :

Hello @Cocaine :wink:

There are a lot of I/O error's. I would assume, that your filesystem is damaged or the HDD is dying.

Boot a desktop iso and try to repair it:

I tried fsck -a /dev/sdb2 where my manjaro installation is. It repaired the system. But i am still facing that problem and can not boot.

Can it because of i ran a sudu command on my manjaro home folder from another distro, and messed up the permission like the @cscs told.

If it is only the home folder, i don’t think so. Even the Kernel modules cannot be loaded. So I hope you have 2 different root partition and don’t overwrite one over another. That would be then the reason for this disaster.

sudo parted -l

This is the output :

And yes i have two different root partitions, is there a way to fix this disaster? As manjaro is my main system, starting over is a pain in the a**

Sooo… this would be then Manjaro:

Model: ATA KINGSTON SA400S3 (scsi)
Disk /dev/sdb: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name  Flags
 1      2097kB  317MB  315MB   fat32                 boot, esp
 2      317MB   231GB  230GB   ext4
 3      231GB   240GB  9449MB  linux-swap(v1)        swap

This is your HDD with Windows and POP OS:

Model: ATA WDC WD10EZEX-08W (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type      File system  Flags
 1      1049kB  577MB   576MB   primary   ntfs         boot
 2      577MB   514GB   513GB   primary   ntfs
 3      514GB   1000GB  486GB   extended               lba
 5      514GB   738GB   224GB   logical   ntfs
 6      738GB   906GB   168GB   logical   ext4
 7      906GB   1000GB  94.4GB  logical   ext4

I see you installed POP OS on msdos and therefore used MBR for grub, but Manjaro uses gpt and therefore EFI, right?

I would say then that grub needs to be reinstalled with Manjaro because POP OS installed Grub on the MBR.

PS: And really: Don’t mix up BIOS and EFI on a single system. Both systems doesn’t work well together with grub.

Yes you are right, ok i will reinstall grub on manjaro and update this msg.

Reinstalling grub also didn’t help :sob: bad luck for me. Thanks for helping.