Can not adjust screen temperature by software like redshift, flux, gammy, any other ways?

Can not adjust screen temporature by software like redshift, flux, gammy, any other ways? like native commands to test if I can adjust screen temporature or find any misconfiguration of my system.
CPU: Intel i5-1240p
GPU: Intel Iris XE
kernel: linux515
laptop is HP Probook 450 G9

I already tried to reinstall drivers by mhwd, lightdm, linux515 kernel, linux-firmware, xorg-server

formatted output from:
inxi -Fazy

since I use and know this one:

how did you install, configure and run it?
(when it did not do what you expected it to do
what was it what you expected it to do
and what happened instead?) :wink:

and, of course, the inxi -Fazy output that @brahma requested would/could be helpful

To make it clear, what I did yesterday is to use clonezilla to clone my original portable 1T HDD to 2T SSD and insert the 2T SSD into my new laptop after you help me fix the boot problem. But actually I find the problem of screen temporature also exist when booting with my original portable disk in my new laptop.

runnig with root:

[my-pc my]# inxi -Fazy
  Kernel: 5.15.50-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=adb6b68e-9f4c-4959-bd8a-b7564d79b8be rw quiet
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 dm: LightDM v: 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: HP ProBook 450 15.6 inch G9 Notebook PC
    v: N/A serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: HP model: 8978 v: KBC Version 07.2D.00 serial: <filter> UEFI: HP
    v: U72 Ver. 01.03.02 date: 05/24/2022
  ID-1: BAT0 charge: 40.0 Wh (78.0%) condition: 51.3/51.3 Wh (100.0%)
    volts: 12.1 min: 11.6 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: discharging cycles: 3
  Info: model: 12th Gen Intel Core i5-1240P socket: U3E1 bits: 64
    type: MST AMCP arch: Alder Lake built: 2021 process: Intel 7 (10nm ESF)
    family: 6 model-id: 0x9A (154) stepping: 3 microcode: 0x41E
  Topology: cpus: 1x cores: 12 mt: 4 tpc: 2 st: 8 threads: 16 smt: enabled
    cache: L1: 1.1 MiB desc: d-8x32 KiB, 4x48 KiB; i-4x32 KiB, 8x64 KiB
    L2: 9 MiB desc: 4x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 781 high: 1167 min/max: 400/4400:3300
    base/boost: 3465/4400 scaling: driver: intel_pstate governor: powersave
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 570 2: 649 3: 681 4: 1101 5: 885
    6: 641 7: 835 8: 741 9: 541 10: 878 11: 1148 12: 1167 13: 563 14: 706
    15: 736 16: 659 bogomips: 67600
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:46a6 class-ID: 0300
  Device-2: Chicony HP HD Camera type: USB driver: uvcvideo bus-ID: 3-1:2
    chip-ID: 04f2:b73b class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: xfwm v: 4.16.1 driver: X: loaded: modesetting unloaded: vesa
    alternate: fbdev gpu: i915 display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0xa08b built: 2019 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.1.2
    direct render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio
    vendor: Hewlett-Packard driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.15.50-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.52 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:5
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 1.82 TiB used: 634.13 GiB (34.0%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SanDisk model: Ultra 3D NVMe
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 21705000 temp: 35.9 C scheme: GPT
  SMART: yes health: PASSED on: 7 hrs cycles: 28
    read-units: 63,153 [32.3 GB] written-units: 1,398,116 [715 GB]
  ID-1: / raw-size: 1.82 TiB size: 1.79 TiB (98.40%) used: 634.08 GiB (34.6%)
    fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 46.5 MiB (15.5%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 42.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 338 Uptime: 9h 44m wakeups: 3386 Memory: 15.27 GiB
  used: 4.03 GiB (26.4%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 2728
  lib: 491 flatpak: 0 Shell: Bash (su) v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.19

I use pamac-manager to install it. I didn’t configure it. In xfce, it shows in bottom right of the screen and when the time comes to night, it will auto adjust the temporature. I find it work in my old laptop. I want to adjust the screen temporature when it comes to night to make my eyes comfortable. In my new laptop, it doesn’t change the screen temporature at night. So I tried other softwares, all didn’t work.

i thought you are running wayland…
so run for example redshift from terminal, and see if there are any logs

I see no errors:

[my@my-pc ~]$ redshift
Trying location provider `geoclue2'...
Using provider `geoclue2'.
Using method `randr'.
Waiting for initial location to become available...
Location: x.x N, x.x E

if you adjust the temperature manually without using geolocation, does it work?

it doesn’t work

[my@my-pc ~]$ redshift -P -O 3000
Using method `randr'.

… with my (working) configuration
this command works - but only for a few seconds
then the configured settings take over again

… the color temp (3000 K) only changes for a very short time - just enough to notice it
white on black terminal text gets reddish for one or a few seconds

this is my configuration - I have set my location manually since I had trouble getting the automatic location provider to work
and I do not change location often enough or far away enough for the resulting difference to truly matter:






I guess it is not the problem of software but OS or hardware because I tried 3 softwares, they all did not work.

If you want to hear my guess:
I don’t think so :wink:

Now I write this conf file into ~/.config/redshift/redshift.conf and change my location and save.
run in the command

[my@my-pc ~]$ redshift
Waiting for initial location to become available...
Location: x.x N, x.x E

but nothing happened on screen

same result here - it is a service which is started with my Xfce session

if I just type “redshift”
nothing will happen
just as you just said

to start it via terminal - give it the proper command line options

or configure and start the service
log out and back in …

and , of course, nothing noticable will happen if your location is at daytime - only at nighttime will it change the color temp to 5000 K (from 6500 K at daytime)

If you used my location - it is well within daytime as of right now …
it’s just past 6 pm and still 3 hours away from sunset :wink:

I insert my SSD to my old laptop. All three softwares work. Now I give up my new laptop. Thank you guys.