Can add printer under KDE but can't under GNOME


I switched from KDE to GNOME because of dual monitor setup (still broken under KDE) and now I try to add my printer, like I did before on KDE.

Bildschirmfoto vom 2022-02-15 08-40-31

IP is set on over the router
install from AUR brother-mfc-j5320dw 3.0.1-3 and brscan4
than I run

sudo brsaneconfig4 -a name=5320DW model=MFCJ5320DW ip=

I reboot but when ever I try to add a printer it shows “cant add printer” and this is it :confused:
I have no idea what the problem could be, just switch to GNOME and didnt touch anything on my setup.

Can somebody help me, please?


Can you try CUPS ?
localhost:631 in the browser adress line.

I never work with CUPS, but it shows OpenPrinting CUPS 2.4.1 and when I try to add a printer it ask me for username and password.

Router username and password is not working, so I try to find it out over the IP and I can only set a password.

@ishaan2479 how u noticed that u need dnssd?

Just enter as username root and as password the root password.

@ishaan2479 gave a relevant solved post on this issue.

You probably need to enable Avahi service:

sudo systemctl enable --now avahi-daemon.service

See Avahi - ArchWiki

@Keruskerfuerst not working, asking again for username and password
@JiaZhang this helps a lot, the printer was instant shown after I rund this command

But still nothing works. When i try to open settings, nothing happen and scanning is also not possible
Bildschirmfoto vom 2022-02-17 11-35-18
Thats the only information I get when i try to open anything.
I also try to add a new printer, it shows me just one printer, not like before but I still can not add


Sorry forgot about this …

That’s odd that you still cannot add the printer.

See this:

But I think you’re new to this printing stuff, so probably see a brief explanation on CUPS:

To be honest, if you need a printer driver from AUR, there’s still a risk that the driver may have some issue (non-functional or the print result is unsatisfactory) and I don’t really recommend using printer driver from AUR even if it’s available. Not to mention that you need to be cautious with AUR caveats, making it not suitable for beginner.

I don’t know how Manjaro KDE was able to functionally support your printer model but not in Manjaro GNOME …


Printer in UNIX and Linux world is quite tricky, and usually vendors only provide an official support as a deb or rpm package:
For you printer model : Downloads | MFC-J5320DW | Others | Brother

So that means that managing printers in deb or rpm distro based is easier.

If the above still doesn’t work, my advice is either below:

  • Switch to Manjaro KDE
  • If you still want GNOME, perhaps try a live-media of deb or rpm distro based with GNOME and see if your printer works, then use that distro instead.

EDIT: fix GNOME KDE typo

I’m so happy right now with GNOME but this is really strange and I’m not able to fix this.
I try it yesterday on Notebook, old one, just install Manjaro KDE.

  1. Install MFC-J5320DW and brscan4 (AUR)
  2. Add printer → IPP Netzwerkdrucker over DNS-SD → Brother MFC-J5320DW CUPS (en) → IP → done
  3. sudo brsaneconfig4 -a name=J5320DW model=MFCJ5320DW ip=

Anything works, scanning and printing, even in very good quality.

Back to GNOME it even find printer and scanner instant.
Bildschirmfoto vom 2022-02-26 12-28-35
But cant scan or print, even when I remove the printer and try to add it again it shows “cant add printer” :confused:

So to clarify, printer was working fine on Manjaro GNOME installed on your old notebook but not with the current computer you’re using. Is that right?

If that’s the case, then I suspect that it’s very likely more to a permission problem. Somehow, you don’t have the permission to configure printer on the laptop you’re using now.

I never use Manjaro GNOME, so I can’t advise further.

@JiaZhang no, I took a old notebook and install Manjaro KDE to test it again and its working without any problem. On GNOME I was not able to print or scan one site :frowning:

With “sudo systemctl enable --now avahi-daemon.service” it adds the printer but still not work

Looks like I found a solution.
First off all you need to install system-config-printer

After that you go to add printer
Bildschirmfoto vom 2022-02-28 00-27-50

Now u type in the adress and wait few sec

Bildschirmfoto vom 2022-02-28 00-29-29

take the last one, go to settings and chose “driver from databank” just look for CUPS (it will show 3 or 4 driver)
Bildschirmfoto vom 2022-02-28 00-34-31

print the first site but scanning still not works :frowning:

edit: I can scan now :smiley:
Just remove it with sudo brsaneconfig4 -r 5320DW and add it like on first post here.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.