[Call for testers] Manjaro Unity Community Edition

Thanks for work Rusdra! I really like unity desktop even more in base arch, I have a modest notebook and it helps a lot to give older devices a chance to survive

Thank you if you check the bug on the lock screen that when it goes to sleep it doesn’t ask for the password, I tried to change it through dconf and through the settings and I couldn’t.

A big hug from Brazil

2 Likes

I believe I’ve found a bug:

Immediately post-installation, I ran a sudo pacman -Syu, and was met with:

error: failed to commit transation (conflicting files)
libindicator-gtk3: /usr/share/libindicator/80indicator-debugging exists in filesystem (owned by libindicator-gtk2)
Errors occurred, no packages were upgraded.

When I tried to remove libindicator-gtk2, it told me it would break unity7.

It would be interesting if, for now, you update via pamac because it worked for me, I had conflicting packages when trying to update through the terminal, but through the manager it was normal

Most likely that is because you used different programs (pacman vs pamac).
If you had used pamac on the cli it should not have behaved differently from it’s UI counterpart.

edit: deleting and reposting so it’s a reply for the main thread

This sounds intriguing to me initially. Somehow I accidentally stumbled upon the GitHub repo before finding this forum thread, and I made the mistake of asking a question there in the Issues. It’s just a basic yes or no question, before I would even commit any time to installing: does this edition include patches to make Mozilla, LibreOffice or any other apps work with the global menu. I wouldn’t think I’d need to install a VM just to get a simple answer to a yes or no question, alas, the only response was to install a VM.

I agree with @TriMoon there needs to be explanation on what needs to be downloaded. I’ve never encountered a split archive before, never had to download more than just one ISO file ever, so it is not intuitive, and it’s not mentioned in the the README, nor even in this forum thread that you have to download two files to get the one ISO (presumption of what is intuitive is always a negative, assumption of what other users have or have not been exposed to is always a negative).

So I finally figured that out, finally installed VirtualBox, and created a new VM, and started it. All I get is a black screen, so I just power off the VM. Maybe I will mess with this again in the future when I have time for it, to just answer my yes or no question that a maintainer could probably answer in five seconds :rofl:

My other pre-install question is, does this project use any files and directories (both under /home/user and /) with the same name as any other desktop environment (e.g., GNOME), thus preventing it from peacefully coexisting with other desktop environments? It would be so nice if every desktop environment just did something like $HOME/.config/unity7 and $HOME/.config/plasma5 … keeping all of its necessary files completely isolated on the file system)

1 Like

Couldn’t set second layout for keyboard, no such option in GUI, gsettings didn’t helped, and I had no time to try further. But I’m waiting for this spin very eagerly, because Unity DE is ideal for me, and I think that it’s most ergonomic DE with optimal usage of screen space. Some options are unique, and in KDE or Budgie I can get only part of this functionality…

Got same error, deleted conflicting file manually and problem was solved

1 Like

Hi all!

Thanks a lot for this! My first test as a fresh install worked nearly complete out of the box, without problems. I also had the “conflicting files bug” (with “pacman -Syu” and the GUI updater as well):

error: failed to commit transation (conflicting files)
libindicator-gtk3: /usr/share/libindicator/80indicator-debugging exists in filesystem (owned by libindicator-gtk2)
Errors occurred, no packages were upgraded.

I could “fix” this by, simply “backup”/renaming the following file:

sudo mv /usr/share/libindicator/80indicator-debugging /usr/share/libindicator/Backup_80indicator-debugging

Another question:
I was surprised, that the gnome-panel is available on pacman, nice! But, it seems there is no autostart tool present, eg “gnome-startup-applications” and that isn’t available through pacman. So, how to easily make eg gnome-panel start on login?

have fun, me (-:

1 Like

I am also experiencing that bug! Otherwise the distro is working fine thus far. Keep up the good work as I am a HUGE fan of unity (used KDE with unity layout).

I’ve been testing this out on Virtual Box. Other than the transaction commit bug when running a “pacman -Syu” command, this has been working great. (I used tuxaddict’s solution to get past it.) I’ve tested out a few apps like LibreOffice with no issues. I’ll keep trying to do a few daily tasks to see if I run into anything, but so far it’s been great.

using it as main system gta if it crash I have too restart pc every time where are the updates programs

I’ve seen a couple of bugs, first some times the animation when you open the app hangs and it “reboot” the desktop and close the app, the second is a dependency issue with libindicator-gtk3/gtk2 is something like loop dependency and it don’t update (sorry for bad English)

Great news, very interesting, because UnityX will get Wayland support. I downloaded the two iso files and have created an install media. Will test it on a laptop. If I have something to say, I will post it. Thanks!

I can confirm this. Same problem.

It was in RC in December. Is it still in RC? I can’t find the download on the community editions list.

I think (someone will correct me) that they are waiting for the UnityX 7.7 release (capable for Wayland) that the developer has planned for Ubuntu 23.04; along with Unity 7.7 (X11).

using it for a long time but the last update broke boot screen have too reinstall ubuntu unity
also are you still working on it ??

Same to mine.And can’t use it.

when will unity 7.7 be updated?