Calendar Panel Widget Skips more than one Month

I am not sure since when the issue exists, but I recently switched to the testing branch, and I am on Wayland since the beginning.
When using the in-panel Calendar widget of Plasma and pressing the “next month” or “previous month” buttons instead of only skipping the current month it skips 3 months. This also happens when if I create a new Panel(Default Panel or Breath Panel).
So steps to reproduce this for me:

  1. Open the Calendar widget within the Panel(the desktop ones “micro programs” work fine)
  2. As you can see on this screenshot it’s “June” and the button says “Next Month”
  3. After I press the button it switches to “September”, and that is obviously not the Month following June.

    Note: As mentioned before this issue only effects the Calendar integrated in the Plasma-panels not a calendar widget created as Desktop “mini-program”.

I noticed this issue yesterday, but I am not sure since when it exists, as mentioned before I switched to testing and I believe when I first setup my PC it worked normal, but it is very well possible that this was a Plasma 6 issue all along.

I have not tried anything to resolve this issue other than creating new panels and check if they have the same issue(they have), testing the “mini-program” widget to see that it does not have this issue(instead skipping from “June” to “July” as intended) and restarting my PC.

I’m on Manjaro Stable and the Plasma version in both Unstable and Testing appears to still be the same as in Stable — i.e. 6.0.5 — but I cannot reproduce what you’re seeing. On my system here it all works as intended. :man_shrugging:

I’m on Testing branch and am experiencing the same issue as the original poster. The problem also occurs when the “Months” (middle) tab of the calendar is selected - instead of the > arrow going to the next year (2025), it jumps to 2027.

1 Like

Found the culprit… The only Plasma-related package in the repo that differs in version is plasma-workspace. Stable has while Testing and Unstable both have

The -2.0 suffix means that it’s an Arch- or Manjaro-specific rebuild or repackaging. The packager is @Yochanan.

PING! :stuck_out_tongue:

1 Like

Working normally here on Unstable beeteedubs.

What are beeteedubses, Preciousss? :thinking:

truncated slang of an enunciated acronym.

beeteedubs - bee tee double-u - btw - by the way. :sweat_smile:


Ah, now we understands. You Americanses with your acronymses… :stuck_out_tongue:

So right now it’s just see and wait? If it already got fixed in unstable and if so for testing to get updated?

Well, @cscs reports that he’s not seeing the problem, and he is indeed running Manjaro Unstable, but the version of plasma-workspace in Unstable is exactly the same as in Manjaro Testing — which is what you’re running — and different from Manjaro Stable, even though it appears to be a packaging or build difference. Because it’s all still, and the suffix only represents the build version or packaging version.

Manjaro Stable   :
Manjaro Testing  :
Manjaro Unstable :

Yet, this package is the only Plasma-related one I could find that actually has a version difference between two of the three Manjaro branches, so I’m assuming that this package will be the culprit. That’s why I’ve pinged the team member who maintains the package. Perhaps he can shed a light on this.


But…but… the only difference is this wee patch based on the following commit that is supposed to fix session restore on Xorg:

Either way, sure I’ll push to stable here shortly.

But from what @Lamdarer and @scotty65 report, is the version with the problem. :man_shrugging:

Then why can’t @cscs reproduce it? Perhaps the difference in packages between Testing and Unstable?

Right, so I won’t push to stable. Sorry, misunderstood. Still cooling down inside with central air after an outside adventure where it’s 91° F / 33° C. :sweat:


I’m on unstable and can reproduce it.

edit: one can get to next/previous month by scrolling via mouse wheel or touchpad.


I rebooted just to be sure …


I just restarted my PC and I can reproduce it, the issue is still present.

However when I first started my PC today and read your post, I had a Plasma “crash”/soft-fail or restart, due to me clicking on the notification icon while another UI element was changing(or for whatever reason). Right after this “Plasma restart” so right after reading your post I was NOT able to reproduce the issue.

It worked fine, however in between the restart of my PC and me checking if the issue is still present Plasma did reinitialize.

So maybe to reproduce this one could try

  1. Restarting the PC.
  2. Login
  3. Checking instantly if the issue is still present, while making sure that Plasma did not crash or reinitialize or whatever.

Or just wait for the merge to arrive downstream and than check if the issue is indeed fixed.

The linked bug report says it’s fixed in 6.1 which is just around the corner (to be released 2024-06-18).

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.