Calamares installer fails on my chipset

Hello all,

I have used manjaro in the past, but have been using gentoo in recent years. However, due to some incompatibilities, I decided to switch back to Manjaro as a daily-driver. Unfortunately, Calamares fails with the error:

The bootloader could not be installed. The installation command <pre>grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force</pre> returned error code 1.

Now, I’ve done this enough to understand that this points to an issue with installing in uefi mode. Typically, this can be caused by the motherboard having any of the following:
1: CSM enabled
2: drive controller set to RAID mode instead of AHCI
3: Fast boot enabled
4: SecureBoot enabled.
5: The motherboard simply does not support UEFI

On my system, none of that is the case.
Furthermore, non-calamares based installers (such as ubuntu) successfully install in UEFI with the exact same hardware and firmware configuration, and any distro that requires a manual install (gentoo, arch) will work with manual configuration of the bootloader, including GRUB.

From the Gentoo Wiki, on installing GRUB:

Some motherboard manufacturers seem to only support the /efi/boot/ directory location for the .EFI file in the EFI System Partition (ESP). The GRUB installer can perform this operation automatically with the --removable option. Verify the ESP is mounted before running the following commands. Presuming the ESP is mounted at /boot (as suggested earlier), execute:
root # grub-install --target=x86_64-efi --efi-directory=/boot --removable
This creates the default directory defined by the UEFI specification, and then copies the grubx64.efi file to the ‘default’ EFI file location defined by the same specification. <

Mine seems to fall under that category (Asrock X570 Extreme4), as any manual install works with that --removable option. However, Calamares lacks both the ability to configure the bootloader via the GUI, or to simply stop the installation before the bootloader phase.

If there is a manual install available, I would use that, but Manjaro-Architect appears to be deprecated.

Booting in BIOS mode is unfortunately not an option, since my system uses an NVME PCIE SSD, and those must be booted by UEFI.

Any help would be appreciated.

You sure you are using a Manjaro ISO?
The error indicates you are using a Garuda ISO…


Ah yes, my mistake. I am indeed using manjaro Iso, I’m just away from my PC at the moment, but will edit it in shortly. I had grabbed that message from my clipboard, not directly from the terminal. that one was from someone else’s issue on the garuda forums, with a pretty similar issue; Garuda is Arch-based and uses calamares as well. aside from “Garuda” the message was identical.

Updated the post with the proper error. Also, I want to thank you for the prompt reply earlier.

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

For a manual install, @linux-aarhus has prepared a guide here: Manjaro Manual Install.

1 Like

That did the trick, thanks :slight_smile:

Glad it’s sorted :slightly_smiling_face:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.