Calamares fails to install boot on EFI partition

Hello, I downloaded Manjaro XFCE and I tried to install it using GPT partition table and with Manjaro as the sole OS on my Notebook.
Notebook Specs:
Samsung RV-511
Intel P6200

Anyways, here are the pictures of my partition table and also the error output.

Can someone tell me what I am doing wrong? Thanks.

I do have this same error as someone else’s in the forum:
Installation Failed

Boost.Python error in job “bootloader”.

Command 'grub-install -target-x86_64-efi -efi-directory-/boot/efi -bootloader-id-Manjaro -force

returned non-zero exit status 1.

Installing for x86_64 efi platform. Could not prepare Boot variable: No space left on device grub-install: error. efibootmgr failed to register the boot entry: Input/output error.


File “/usr/lib/calamares/modules/bootloader/”, line 476, in run prepare_bootloader (fw_type)

File “/usr/lib/calamares/modules/bootloader/”, line 448, in prepare_bootloader install_grub(efi_directory, fw_type)

File “/usr/lib/calamares/modules/bootloader/”, line 310, in install_grub


File “”, line 6, in

Maybe take a look here Unable to install Manjaro KDE on eMMC: Install Grub Issue - #24 by SimonJ

can you boot on your USB iso manjaro
open a terminal and a browser on this topic
and returns

inxi -Fza 
sudo parted -l
sudo efibootmgr -v
test -d /sys/firmware/efi && echo efi || echo bios

Hello, Here’s the output of the commands. Last one didn’t return anything.

  Kernel: 5.10.26-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_XFCE_2101 quiet 
  systemd.show_status=1 apparmor=1 security=apparmor driver=free 
  nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: SAMSUNG product: RV411/RV511/E3511/S3511/RV711/E3411 
  v: N/A serial: <filter> Chassis: type: 9 serial: <filter> 
  Mobo: SAMSUNG model: RV411/RV511/E3511/S3511/RV711/E3411 serial: <filter> 
  UEFI: Phoenix v: 04PA.M006.20110615.XW date: 06/15/2011 
  ID-1: BAT1 charge: 0% condition: N/A/48.8 Wh volts: N/A min: 11.1 
  model: SAMSUNG Electronics type: Li-ion serial: N/A status: Unknown 
  Info: Dual Core model: Intel Pentium P6200 bits: 64 type: MCP 
  arch: Nehalem family: 6 model-id: 25 (37) stepping: 5 microcode: 7 cache: 
  L2: 3 MiB 
  flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 8514 
  Speed: 931 MHz min/max: 933/2133 MHz Core speeds (MHz): 1: 931 2: 931 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Core Processor Integrated Graphics vendor: Samsung Co 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0046 class-ID: 0300 
  Device-2: Silicon Motion WebCam SCB-0385N type: USB driver: uvcvideo 
  bus-ID: 1-1.4:3 chip-ID: 2232:1005 class-ID: 0e02 
  Display: x11 server: X.Org 1.20.10 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (ILK) v: 2.1 Mesa 21.0.1 
  direct render: Yes 
  Device-1: Intel 5 Series/3400 Series High Definition Audio 
  vendor: Samsung Co driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
  chip-ID: 8086:3b56 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.26-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.24 running: no 
  Device-1: Broadcom BCM4313 802.11bgn Wireless Network Adapter 
  vendor: Askey driver: bcma-pci-bridge v: N/A modules: bcma port: 1840 
  bus-ID: 02:00.0 chip-ID: 14e4:4727 class-ID: 0280 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Samsung Co driver: r8169 v: kernel port: 3000 bus-ID: 04:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp4s0 state: down mac: <filter> 
  Device-3: KYE Systems (Mouse Systems) GF3000F Ethernet Adapter type: USB 
  driver: hid-generic,usbhid bus-ID: 2-1.5:6 chip-ID: 0458:6001 
  class-ID: 0301 
  IF-ID-1: wlp2s0b1 state: up mac: <filter> 
  Device-1: Broadcom Broadcom BCM2070 Bluetooth Device type: USB 
  driver: btusb v: 0.8 bus-ID: 2-1.3:5 chip-ID: 0a5c:219c class-ID: fe01 
  serial: <filter> 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
  Local Storage: total: 494.64 GiB used: 0 KiB (0.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: HN-M500MBB 
  size: 465.76 GiB block-size: physical: 4096 B logical: 512 B 
  speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 0001 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Kingston 
  model: DataTraveler 3.0 size: 28.88 GiB block-size: physical: 512 B 
  logical: 512 B serial: <filter> rev: PMAP scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No Partition data was found. 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 43.0 C mobo: 43.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 181 Uptime: 3m wakeups: 1 Memory: 3.64 GiB 
  used: 1014.9 MiB (27.2%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: N/A Packages: pacman: 1133 lib: 300 flatpak: 0 Shell: Bash v: 5.1.0 
  running-in: xfce4-terminal inxi: 3.3.03 
Model: ATA SAMSUNG HN-M500M (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name       Flags
 5      1049kB  1075MB  1074MB  fat32           /boot/efi  msftdata
 1      1075MB  2149MB  1074MB  fat32           /boot      msftdata
 2      2149MB  10.7GB  8590MB  linux-swap(v1)             swap
 3      10.7GB  43.0GB  32.2GB  ext4
 4      43.0GB  500GB   457GB   ext4

Model: Kingston DataTraveler 3.0 (scsi)
Disk /dev/sdb: 31.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2535MB  2540MB  4194kB  primary               esp

Timeout: 10 seconds
No BootOrder is set; firmware will attempt recovery

Please consider that the first two partitions (namely /boot/efi and /boot) were an attempt to make it work, it didnt.
I also tried with the correct “boot” flags, one single partition, etc.
Should I just Give up?
Or I can install Manjaro as an MSDOS partition?
I can live with it being msdos and not UEFI.

there is missing flag on /boot/efi for Boot& esp ( add with Gparted from USB iso manjaro )
in case of /boot also it required boot&esp

difference between /boot/efi and /boot

in case of /boot/efi only grub & config grub are installed ( less than 2% for 100Mo partition )
in case of /boot grub & config grub , also all kernels img & initrd & microcode are inside ,
as we can add many kernels , its should more than 512 to 768 Mo

in your UEFI motherboard

disable secure boot
disable fast boot
disks on AHCI
no legacy
no CSM
UEFI only or others ( not windows )

you should see
UEFI < USB vendor name > < partition 1 > → boot in EFI

you can check in terminal , after boot USB iso manjaro

inxi -Mxa ( check for UEFI only , not UEFI[legacy] or Bios )
test -d /sys/firmware/efi && echo efi || echo bios

Hello stephane, Thanks for your reply.
Sadly Manjaro doesn’t work with my computer, final decision.
I won’t pursue manjaro anymore, plenty of fish.
Have a nice day.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.