Built-in laptop mic not working

Having an odd issue, my built-in mic on my ThinkPad T460 is not working or even recognized as a device in Audio System Settings. It was working at one point and then it stopped. I believe this occurred after I had used a Griffin iMic (which is a usb input and output audio adapter). I suspect that my audio configuration may somehow be corrupt, but I have no clue where to begin my troubleshooting.

To test if it was my install of Manjaro or a hardware issue, I booted a live Manjaro session and my mic is recognized and functions just fine.

Let me know if additional detail or other specific information is needed.

Then post
inxi -Fzxxxa

and the output of
alsamixer (on console).

Here’s inxi -Fzxxxa

System:
Kernel: 5.4.57-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.4-x86_64 
root=UUID=2930a0bf-fdb6-4638-afe5-37979b9e0fe9 rw rootflags=subvol=@ quiet 
cryptdevice=UUID=a70a7d26-f8c2-41c6-b7ce-4b6a601b8fbb:luks-a70a7d26-f8c2-41c6-b7ce-4b6a601b8fbb 
root=/dev/mapper/luks-a70a7d26-f8c2-41c6-b7ce-4b6a601b8fbb 
resume=/dev/mapper/luks-a70a7d26-f8c2-41c6-b7ce-4b6a601b8fbb apparmor=1 
security=apparmor udev.log_priority=3 
Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 
dm: SDDM Distro: Manjaro Linux 
Machine:
Type: Laptop System: LENOVO product: 20FN002NUS v: ThinkPad T460 
serial: <filter> Chassis: type: 10 serial: <filter> 
Mobo: LENOVO model: 20FN002NUS v: SDK0J40705 WIN serial: <filter> 
UEFI: LENOVO v: R06ET68W (1.42 ) date: 10/08/2019 
Battery:
ID-1: BAT0 charge: 3.9 Wh condition: 19.1/23.2 Wh (83%) volts: 12.1/11.1 
model: SONY 45N1111 type: Li-poly serial: <filter> status: Charging 
ID-2: BAT1 charge: 0.8 Wh condition: 19.1/23.5 Wh (81%) volts: 11.1/11.4 
model: LGC 45N1127 type: Li-ion serial: <filter> status: Unknown 
CPU:
Topology: Dual Core model: Intel Core i5-6300U bits: 64 type: MT MCP 
arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: D6 
L2 cache: 3072 KiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
bogomips: 20004 
Speed: 2700 MHz min/max: 400/3000 MHz Core speeds (MHz): 1: 2721 2: 2750 
3: 2738 4: 2797 
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
Type: l1tf 
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass 
mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 
mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds status: Vulnerable: No microcode 
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915 
v: kernel bus ID: 00:02.0 chip ID: 8086:1916 
Device-2: Acer ThinkPad P50 Integrated Camera type: USB driver: uvcvideo 
bus ID: 1-10:4 chip ID: 5986:0706 
Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: intel 
unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
s-diag: 582mm (22.9") 
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 157 size: 310x170mm (12.2x6.7") 
diag: 354mm (13.9") 
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.1.5 
direct render: Yes 
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 
chip ID: 8086:9d70 
Sound Server: ALSA v: k5.4.57-1-MANJARO 
Network:
Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: 3.2.6-k 
port: efa0 bus ID: 00:1f.6 chip ID: 8086:156f
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: efa0
bus ID: 04:00.0 chip ID: 8086:24f3
IF: wlp4s0 state: up mac: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 507.26 GiB (54.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda vendor: SanDisk model: SDSSDH3 1T00 size: 931.51 GiB
block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
serial: <filter> rev: 40RL scheme: GPT
Partition:
ID-1: / raw size: 929.22 GiB size: 929.22 GiB (100.00%)
used: 507.10 GiB (54.6%) fs: btrfs dev: /dev/dm-0
ID-2: /home raw size: 929.22 GiB size: 929.22 GiB (100.00%)
used: 507.10 GiB (54.6%) fs: btrfs dev: /dev/dm-0
Swap:
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 2.00 GiB used: 160.5 MiB (7.8%)
priority: -2 dev: /dev/sda3
Sensors:
System Temperatures: cpu: 62.0 C mobo: N/A
Fan Speeds (RPM): cpu: 4085
Info:
Processes: 271 Uptime: 38m Memory: 11.56 GiB used: 4.55 GiB (39.3%)
Init: systemd v: 245 Compilers: gcc: 10.1.0 clang: 10.0.1 Packages: 1903
pacman: 1894 lib: 465 flatpak: 0 snap: 9 Shell: Bash v: 5.0.18
running in: konsole inxi: 3.1.05

And here’s alsamixer

β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€ AlsaMixer v1.2.3 ──────────────────────────────┐
β”‚ Card: PulseAudio                                     F1:  Help               β”‚
β”‚ Chip: PulseAudio                                     F2:  System information β”‚
β”‚ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  β”‚
β”‚ Item: Master                                         Esc: Exit               β”‚
β”‚                                                                              β”‚
β”‚                                                                              β”‚
β”‚                                     β”Œβ”€β”€β”                                     β”‚
β”‚                                     β”‚  β”‚                                     β”‚
β”‚                                     β”‚  β”‚                                     β”‚
β”‚                                     β”‚  β”‚                                     β”‚
β”‚                                     β”‚  β”‚                                     β”‚
β”‚                                     β”‚  β”‚                                     β”‚
β”‚                                     β”‚  β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”œβ”€β”€β”€                                     β”‚
β”‚                                     β”‚OOβ”‚                                     β”‚
β”‚                                     β””β”€β”€β”˜                                     β”‚
β”‚                                    56<>56                                    β”‚
β”‚                                  < Master >                                  β”‚
β”‚                                                                              β”‚
β”‚                                                                              β”‚
β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜

If you press F4 on AlsaMixer does it show any capture devices? Sometimes this defaults to 0 volume.

1 Like

Here’s the capture devices with the β€œdefault” sound card selected.

β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€ AlsaMixer v1.2.3 ──────────────────────────────┐
β”‚ Card: PulseAudio                                     F1:  Help               β”‚
β”‚ Chip: PulseAudio                                     F2:  System information β”‚
β”‚ View: F3: Playback  F4:[Capture] F5: All             F6:  Select sound card  β”‚
β”‚ Item: Capture                                        Esc: Exit               β”‚
β”‚                                                                              β”‚
β”‚                                                                              β”‚
β”‚                                     β”Œβ”€β”€β”                                     β”‚
β”‚                                     β”‚  β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                     β”‚β–’β–’β”‚                                     β”‚
β”‚                                    Lβ””β”€β”€β”˜R                                    β”‚
β”‚                                   CAPTURE                                    β”‚
β”‚                                    95<>95                                    β”‚
β”‚                                  <Capture >                                  β”‚
β”‚                                                                              β”‚
β”‚                                                                              β”‚
β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜

And here’s the capture devices with the β€œHDA Intel PCH” card selected.

β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€ AlsaMixer v1.2.3 ──────────────────────────────┐
β”‚ Card: HDA Intel PCH                                  F1:  Help               β”‚
β”‚ Chip: Realtek ALC293                                 F2:  System information β”‚
β”‚ View: F3: Playback  F4:[Capture] F5: All             F6:  Select sound card  β”‚
β”‚ Item: Capture [dB gain: 30.00, 30.00]                Esc: Exit               β”‚
β”‚                                                                              β”‚
β”‚                                                                              β”‚
β”‚        β”Œβ”€β”€β”               β”Œβ”€β”€β”               β”Œβ”€β”€β”               β”Œβ”€β”€β”         β”‚
β”‚        β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚         β”‚
β”‚        β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚         β”‚
β”‚        β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚         β”‚
β”‚        β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚         β”‚
β”‚        β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚         β”‚
β”‚        β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚         β”‚
β”‚        β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚         β”‚
β”‚        β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚         β”‚
β”‚        β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚         β”‚
β”‚        β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚         β”‚
β”‚        β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚         β”‚
β”‚        β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚         β”‚
β”‚        β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚               β”‚β–’β–’β”‚         β”‚
β”‚        β””β”€β”€β”˜              Lβ””β”€β”€β”˜R              β””β”€β”€β”˜               β””β”€β”€β”˜         β”‚
β”‚                         CAPTURE                                              β”‚
β”‚      100<>100           100<>100           100<>100           100<>100       β”‚
β”‚     Mic Boost     <     Capture      >  Dock Mic Boost   Internal Mic Boost  β”‚
β”‚                                                                              β”‚
β”‚                                                                              β”‚
β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜

Despite this, Audio settings still doesn’t show any recording or capture device.

Have you can got Pulse Audio Volume Control install, if so you maybe able to choose default input device there.

I do have Pulse Audio Volume Control, but it shows no recording or input devices either.


Solution to get audio again:

Open /etc/modprobe.d/alsa-base.conf and add the following line at the end:

options snd-hda-intel dmic_detect=0

Then:

pulseaudio -k && sudo alsa force-reload

/etc/modprobe.d/alsa-base.conf didn’t exist, I created the file and added the line

options snd-hda-intel dmic_detect=0

Then I ran

pulseaudio -k && sudo alsa force-reload

and Pulse Audio reloaded, but the alsa command could not be found.

My terminal output:

sudo: alsa: command not found

I believe I finally have this problem solved, time will tell if it happens again when I connect and use my Griffin iMic.

I found the solution here, on the Arch Wiki.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.