Built-in Keyboard and USB mic/mouse randomly disconnecting

Hello everyone! First post here so I hope it’s formatted correctly.

I’ve been running manjaro linux xfce for a months now without any major issues. I started using it for programming and it has served that purpose very well. I also do some gaming (minecraft, cs go, a ton of other games). Yesterday, I was in a Discord call and playing CS: GO when my keyboard, mouse, and microphone just stopped working. I’m running on an Asus Rog Zephyrus G14 with a USB mouse/and USB Mic and the built on keyboard. I couldn’t open a terminal or do anything except left and right click with my touch pad. I had to restart my computer and the problem went away…for a while when it did it again. It happened a few more times that night until I logged off. I used my computer for several hours today and it worked fine until I tried to play a game while also participating in a Discord call until the keyboard and mouse stopped again. I was able to restart but then it happened again not long after I started Discord.
I’m really not sure if Discord is the issue because it’s also happened without using Discord.


  Host: gurgi Kernel: 6.0.0-1-MANJARO arch: x86_64 bits: 64 Desktop: Xfce
    v: 4.16.1 Distro: Manjaro Linux
  Type: Laptop System: ASUSTeK product: ROG Zephyrus G14 GA401QM_GA401QM
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: GA401QM v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: GA401QM.410 date: 12/13/2021
  ID-1: BAT0 charge: 63.9 Wh (96.2%) condition: 66.4/76.0 Wh (87.3%)
    volts: 15.8 min: 15.8
  Info: 8-core model: AMD Ryzen 9 5900HS with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 2076 min/max: 1200/4679 cores: 1: 1916 2: 3300 3: 1930
    4: 1200 5: 1200 6: 1200 7: 2041 8: 2374 9: 3300 10: 1916 11: 1200 12: 2485
    13: 2187 14: 2603 15: 2393 16: 1982
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] driver: nvidia
    v: 515.76
  Device-2: AMD Cezanne driver: amdgpu v: kernel
  Display: x11 server: X.Org v: 21.1.4 driver: X:
    loaded: modesetting,nvidia dri: radeonsi gpu: amdgpu
    resolution: 1920x1080~144Hz
  OpenGL: renderer: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2 v: 4.6.0
    NVIDIA 515.76
  Device-1: NVIDIA GA106 High Definition Audio driver: snd_hda_intel
  Device-2: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
  Device-4: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Device-5: ONN 100009002 type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.0-1-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e
  IF: wlan0 state: up mac: 90:e8:68:10:82:29
  Device-1: IMC Networks Wireless_Device type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 606.91 GiB (63.6%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLQ1T0HBLB-00B00
    size: 953.87 GiB
  ID-1: / size: 62.44 GiB used: 46.35 GiB (74.2%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 41.9 MiB (14.0%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 776.11 GiB used: 560.53 GiB (72.2%) fs: ext4
    dev: /dev/nvme0n1p3
  Alert: No swap data was found.
  System Temperatures: cpu: 62.1 C mobo: N/A
  Fan Speeds (RPM): cpu: 2800
  GPU: device: nvidia screen: :0.0 temp: 47 C device: amdgpu temp: 49.0 C
  Processes: 325 Uptime: 8m Memory: 15.04 GiB used: 2.08 GiB (13.8%)
  Shell: Bash inxi: 3.3.22

Thank you for your help!

I have done some more research, and determined the issue occurs not when in a call necessary, but when I plug in a new mic I bought recently. I have also searched this issue online and not found any issues. Any help would be greatly appreciated!