Building qt5-webkit takes a long time to update then fails

hi, not sure is this is the correct forum, but qt5-webkit is in the AUR so I chose this one.

I noticed that “qt5-webkit” takes a very long time to update, even in my DELL Inspiron 5559 (2015) it took hours but did finally update. but on my very old (2008) SONY VAIO it takes a a very long while then fails.

trying to update from 5.212.0alpha4-15 to 5.212.0alpha4-19

here’s the last few lines from pamac…

       |             ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
 make[1]: *** [CMakeFiles/Makefile2:1380: Source/WebCore/CMakeFiles/WebCore.dir/all] Error 2
 make: *** [Makefile:166: all] Error 2
 ==> ERROR: A failure occurred in build().

sorry it looks like it doesn’t tell you a lot. I’m on Xfce desktop.

I checked on google and found what looks like good solution on…

it suggest that you can install a version through the archive with…

pacman -U

if this is a good solution, before I run this command, I just wondered if I need to uninstall qt5-webkit first beforehand, or do I just open terminal and do the update.

any advice would be appreciated, thanks.

1 Like

Do you need it ?

pactree -r qt5-webkit

Its not really a long-term good solution as the archive wont be updated.
Otherwise it should work alright … no you dont need to uninstall first.

1 Like

What do you have installed that requires qt5-webkit? Arch dropped it to the AUR last November as it’s deprecated and insecure.

pactree should tell us.

The longer story is that while webkit was initially QT-based (being taken from KDE) recent webkit is actually toolkit agnostic (supposedly this has to do with apple updating it) … so now the QT version is deprecated and has no need (unless you are running software that still depends on it).

Somewhat related … there is a project to re-QT-ify webkit.

I had the same issue myself, it was a dependency of TeamViewer. I don’t use TeamViewer (had to use it once lol) so I just uninstalled both packages. I have a msi gaming laptop and it was maxing out my laptop trying to build it for ages

me too … :sleepy:
for zeal no updated since 2020 (but -git use qt6-webengine), at me to change … EDIT: ok qt5-webkit removed

Same qt5-webkit update problems for me. Could not figure out why it was installed. Have now removed it. If there are any problems, I will report them.

If you use pamac gui it will tell you what it is/was a dependency of. That’s how I spotted TeamViewer

I ran the command you suggested…

$ pactree -r qt5-webkit

I am not an expert, this looks like I can uninstall this package?

1 Like

That means nothing depends on it.
Go ahead and remove it unless you have some reason to keep the orphan around.

sudo pacman -Rns qt5-webkit

thanks for your advice @cscs, much appreciated, that’s it deleted :+1:

and thanks to everyone for your replies, great responses.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.