Building labwc hangs under Sway Raspberry Pi 4B

Hi there,

when I try to configure labwc from git, under Sway stable branch, on my Raspberry Pi 4B, cloning wlroots hangs forever. I already built it previously so I wonder if there’s a known bug in recent meson that would explain why it hangs.

I follow the build instructions here :

When I run “meson build” it hangs with the message “Cloning into ‘wlroots’…” so it seems to hang in wlroots.wrap subproject.

Thanks in advance. :slight_smile:

wlroots git handed one or two days.
so, i download its zip file to compile for sway-git.
or, you might compile wlroots-1.15.

Did you try building the AUR package?

You just need to add aarch64 to the arch=() line.

I didn’t try to download the zip sources or to build the AUR package yet. I will try, thanks a lot. :stuck_out_tongue:

In fact it seems that cloning the gitlab repository hangs for some reason.

If I try :

git clone

It waits eternally for something and only Ctrl+C can terminate the process.

The freedesktop gitlab instance might be having issues. It happens from time to time.

I understand, I’ll try the AUR package and will try git later. Thanks a lot :slight_smile:

I am a bit curious about labwc myself. I have just started to use sway… it supports floating windows, does labwc add something to sway?

It’s a clone of Openbox for Wayland, last time I tried it, I had a few bugs, I’m not sure if it’s usable yet but it seems promising IMO. That’s why I’d like to build it from git from time to time, to see how it progresses. For now, I had to switch to unstable branch because it requires recent versions of packages and also Gitlab doesn’t want to cooperate. Github was much more reliable. :smiley:

Ah, right there in front of me… it is a compositor. I thought it was something to add to sway. I am now following the project, it has my interest.

wlroots gitlab alive again.

Yes! It’s alive! :smiley: I’m writing this message from labwc and suddenly I understand why these little red crosses : Commits · labwc/labwc · GitHub :stuck_out_tongue:

Cloning into 'wlroots'...

fatal: unable to access '': The requested URL returned error: 504

Thanks a lot. :slight_smile:

do you have mouse issue while start firefox?

No, but I use keyboard shortcuts to run programs :stuck_out_tongue:

(see <!-- Custom keys start -->)

Maybe that’s why I don’t have an issue.

firefox surf by keyboard?

Launching Firefox from keyboard shortcut and no mouse issue for now.

which wlroots & labwc build?

From labwc’s git :

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.