Build error in AUR packages for QGIS

Hello, I’m a QGis user and I actually switched to Manjaro because of this AUR package (gdal-ecw) that enabled support for a especific type of raster image (a proprietary type of .jp2). It worked well until I had to re-install my OS from scratch (I installed it on version 20.1, FWIW) but now, when I try to build this package again, I get a build error with a required package called “libecwj2”. I’m wondering if there is a compatibility issue that arose in recent updates of either the OS or QGis, or if I’m doing something wrong (as I’m still a bit new to Linux)? Any help is appreciated.

libtool: compile:  g++ -DHAVE_CONFIG_H -I. -D_GNU_SOURCE -D_REENTRANT -DLIBECWJ2 -DLINUX -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DPOSIX -I/home/diegos/.cache/yay/libecwj2/src/libecwj2-3.3/Source/include -Wall -Wno-long-long -fno-common -fpic -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2,-D_GLIBCXX_ASSERTIONS -Wformat -Werror=format-security -fstack-clash-protection -fcf-protection -MT ../C/NCSGDT2/NCSGDTEpsg.lo -MD -MP -MF ../C/NCSGDT2/.deps/NCSGDTEpsg.Tpo -c ../C/NCSGDT2/NCSGDTEpsg.cpp -o ../C/NCSGDT2/NCSGDTEpsg.o >/dev/null 2>&1
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -D_GNU_SOURCE -D_REENTRANT -DLIBECWJ2 -DLINUX -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DPOSIX -I/home/diegos/.cache/yay/libecwj2/src/libecwj2-3.3/Source/include -Wall -Wno-long-long -fno-common -fpic -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2,-D_GLIBCXX_ASSERTIONS -Wformat -Werror=format-security -fstack-clash-protection -fcf-protection -MT ../C/NCSUtil/log.lo -MD -MP -MF ../C/NCSUtil/.deps/log.Tpo -c ../C/NCSUtil/log.cpp -o ../C/NCSUtil/log.o >/dev/null 2>&1
make[3]: se sale del directorio '/home/diegos/.cache/yay/libecwj2/src/libecwj2-3.3/Source/NCSBuildGnu'
make[2]: *** [Makefile:1231: all] Error 2
make[2]: se sale del directorio '/home/diegos/.cache/yay/libecwj2/src/libecwj2-3.3/Source/NCSBuildGnu'
make[1]: *** [Makefile:364: all-recursive] Error 1
make[1]: se sale del directorio '/home/diegos/.cache/yay/libecwj2/src/libecwj2-3.3/Source'
make: *** [Makefile:575: all-recursive] Error 1
==> ERROR: Se produjo un fallo en build().

Updated with the last lines of terminal (sorry for the Spanish in there), hope it helps. Thanks again.

What if you first build libecwj2 and then try to build gdal-ecw

I tried that as well. Same thing (should have mentioned it in the first post, sorry). I tried it both within Add/Remove and on terminal with Yay.

The small bit of the build log you posted doesn’t tell us why it failed. Please post the full log. If it’s long, use a pastebin service and link it here.

This time, please prefix the build command with LC_ALL=C so it’s in English; i.e.,

LC_ALL=C pamac build gdal-ecw

I have successfully compiled libecwj2 with both makepkg and in chroot

Let me know if it helps

[Terminal build log](

That bit of the build log is only for the libecwj2 dependency. The AUR package already has several patches, they probably need adjusting or new patches. Upstream has more info here.

Why are you building qgis-1.6 when qgis is in the community repo?

I included the log for libecwj2 because that’s the required package that’s refusing to build for gdal-ecw.

Why are you building qgis-1.6 when qgis is in the community repo?

That’s weird. I have QGis 3.18 already installed from the official repos.

@Lolix I wonder what it is I’m missing. In my previous installation it updated several times without a hitch. It all started when I had to make a fresh install.

Oh, I thought you were installing gdal-ecw as a dependency for qgis-1.6. I guess I misunderstood.

Using which branch? It failed for me on unstable with the same errors @DiegoS91 had.


gdal-ecw instead fails to build for me for an error related to man pages installation, i 3 versions 3.2.2, 3.2.3, 3.3.0

So it seems like a problem with the package(s), right? Although I find interesting @Lolix managed to build libecwj2 but gdal-ecw failed.

I try to download fresh Manjaro-xfce-21.0.7-210614-linux510.iso. Then I update the system. Then I install libecwj2. It failed.
Then I try to install gdal-ecw. It failed too.
So, is there solution?
I try to install QGIS with ecw enable.