Bugs with the latest update?

since the last update i had these issues
1- the touchpad is all over the place , it’s basically unusable
tried to change the kernel to 5.4 , the same problem , irratic movement , and uncontrollable
i had to use a mouse for now
my device is " AlpsPS/2 ALPS GlidePoint touchpad"
there is nothing in dmesg or journalctl

2- there is permissions bugs
if i want to put the laptop to sleep , now i have to give it a password
even if i shutdown the lid , which should put it to sleep , it keeps the monitor running and asks for the password

3- hibernate button disappears from the logout menu whenever issue 2 happens

4- there is screen tearing from the top (noticeable with fast motion videos) while watching a video
my video driver is mesa

what i think is the problem is :
1- there is some issue with libinput
2- there is an issue with polkit / xfce power manager permissions
3- video hardware acceleration / mesa ?

Please post the output of inxi -Fazy --filter

  Kernel: 5.10.70-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=9c7facb5-5aa4-460f-a3cc-7d96cfaec496 rw quiet apparmor=1
  security=apparmor resume=UUID=77f824f0-ed5e-4eef-ada7-475826ae26e2
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: plank, xfce4-panel
  wm: xfwm 4.16.1 vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux
  base: Arch Linux
  Type: Laptop System: Dell product: Latitude E6420 v: 01 serial: <filter>
  Chassis: type: 9 serial: <filter>
  Mobo: Dell model: 0K0DNP v: A01 serial: <filter> BIOS: Dell v: A25
  date: 03/06/2018
  ID-1: BAT0 charge: 1.7 Wh (16.2%) condition: 10.5/62.2 Wh (16.9%)
  volts: 11.2 min: 11.1 model: Samsung SDI DELL 5CGM417 type: Li-ion
  serial: <filter> status: Discharging
  Info: Dual Core model: Intel Core i5-2520M bits: 64 type: MT MCP
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F
  cache: L2: 3 MiB
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19962
  Speed: 882 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 882 2: 801 3: 802
  4: 815
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
  vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0126
  class-ID: 0300
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver:
  loaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
  s-diag: 414mm (16.3")
  Monitor-1: LVDS-1 res: 1366x768 hz: 60 dpi: 112 size: 309x173mm (12.2x6.8")
  diag: 354mm (13.9")
  OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2)
  v: 3.3 Mesa 21.2.3 compat-v: 3.0 direct render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
  vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  chip-ID: 8086:1c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.10.70-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: yes
  Device-1: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
  v: kernel bus-ID: 02:00.0 chip-ID: 8086:0082 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
  v: 3.0 port: 3060 bus-ID: 00:1f.2 chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 698.64 GiB used: 426.02 GiB (61.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST9750420AS
  size: 698.64 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
  type: HDD rpm: 7200 serial: <filter> rev: SDM5 scheme: MBR
  ID-1: / raw-size: 42.97 GiB size: 42.04 GiB (97.85%) used: 24.02 GiB (57.1%)
  fs: ext4 dev: /dev/sda6 maj-min: 8:6
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 5.86 GiB used: 325.8 MiB (5.4%)
  priority: -2 dev: /dev/sda5 maj-min: 8:5
  System Temperatures: cpu: 54.0 C mobo: 30.0 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 0
  Processes: 205 Uptime: 1d 2h 2m wakeups: 70 Memory: 3.72 GiB
  used: 2.21 GiB (59.4%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1319 lib: 411 Shell: Bash v: 5.1.8
  running-in: xfce4-terminal inxi: 3.3.08

For screen tearing: Intel graphics - ArchWiki

i have solved problems number 2 and 3
the hibernate problem and permession problems while trying to suspend was due to pamac
it prevented sleep (i don’t know why) , and it broke some permissions so the hibernate button doesn’t appear in logout menu (neither do suspend)
it was running by default in xfce startup (as updater service) , so i disabled it , and the issue was resolved
im still trying to figure out the touchpad problem , this is the most annoying of all (libinput ?)
im asking devs to please fix pamac issues , it’s a great tool , but it needs a bit of auditing
i will mark this as resolved for now

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.