Bugs accumulated after updates

Dolphin and other KDE / Qt file selection dialogs do not display one of the mounted hdd, while GTK applications do. How to fix it?

There is an option “Allow applications to block the mode with graphic effects”, for example: the game starts, this option works, the effects are turned off, the game is closed, the effects are turned on, but after that it lags the window moving, scrolling, and video playback. How to fix it? Nvidia nonfree

Dolphin now has an option to mount ISO, but it doesn’t work. How to fix it?

It is generally better to ask one question in … well… one question as now you need an expert on QT/GTK, nVidia and Dolphin whereas if you asked 3 questions, you need 3 different experts, and they’re easier to find.

Also, please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

:innocent:

Just tried this out and it worked for me,
Have you rebooted since last update? :slight_smile:

Yes (always reboot after update).

Also html is displayed where it is not needed

https://bugs.kde.org/show_bug.cgi?id=422616

1 Like

Dolphin does not display free disk space after the last update.

It does for me.

Make sure that the setting: Dolphin Settings -> General -> Statusbar -> Show Storage Information is checked.

1 Like

This option was enabled but stopped working. Need to open and close the tab or the Dolphin itself, then it works for a short time.

Same here for me…
No more displaying free space with dolphin even after the latest update.

From my experience, when you are facing different little problems after an update related to the interface (such as things not shown correctly etc.) many times helps deleting (backing-up) some configuration files from your ~/home/user folder so they get reset (recreated).

Config files usually located under for example:
.config/
.local/share/
etc.

The downside is that in some cases you could loose your custom configuration (e.g. number of desktops), but in the end you end in a new configuration without problems that could arise after an update and without the need of reinstalling or searching around for hours.

At least you’ve got a point to start.

Yes, i will try it in last resort.
I use the console and it occurs this:

  [marc@marc-pc ~]$ dolphin
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 694, resource id: 0, major code: 20 (GetProperty), minor code: 0
kf.kio.core: We got some errors while running testparm "Error loading services."
kf.kio.core: We got some errors while running 'net usershare info'
kf.kio.core: "Can't load /etc/samba/smb.conf - run testparm to debug it\n"

Maybe in case you have never used samba share in order to share files with a windows network, no smb.conf file has been created in the indicated location. That could be the reason that cannot find that file.

Elsewhere, you could try to make a backup of your smb.conf file and recreate it in order to see if the error gets solved.