Buggy Zsh integration with Dolphin's embedded terminal

if Dolphin launches with the embedded terminal open it messes it up.

You may think the video is descriptive.
It’s not - not to me.

What do you expect vs what is happening?
Use words. :wink:

the Zsh graphics don’t load.
its terminal line start icon thing
image
gets replaced with “vm-virtualbox%”.

Seems unrelated to zsh as it happens to me too and I’m using bash. My mistake, watched your video again and see what you mean, but the there is weird behaviour upon reopening the terminal, on the second opening it shows:

[ydar@homepc /]$ ^C
[ydar@homepc /]$  cd /home/ydar

This is not something I’ve seen before.

Also may or may not be related to this bug: 455324 – Terminal open/closed state is incorrectly restored

so: it’s just inconsistent appearing prompts?

… switch to a terminal profile which is using bash instead of zsh
as the shell

these, by default zsh using profiles
are the most annoying thing in Manjaro KDE … to me

A very bad design decision, if you ask me. …

especially new users do not know whether they are using bash or zsh
and are confused to no end

it’s just inconsistent

Why do ‘Youtube’(?) vids appear at the end of the example?

It’s true, sometimes Dolphin’s terminal doesn’t load properly - with zsh I notice this… but as usual, today I can’t replicate it (maybe my recent rebuild solved this).
Quite often after I did F4 I had to type zsh to get it loaded.

Anyway, after that video, I think we need a nice shot to show why we love zoxide in a terminal in Dolphin, especially when we’re looking for some TV show to delete:

But sure, OP is correct.

There’s also another issue I had with Konsole which comes up if I resize a window:

So let’s ignore that, coz I don’t know how to fix that either (and that is the same with Alacritty, but not with KiTTY).

This doesn’t help this thread.

And I was mostly just voicing my opinion about the Konsole profiles in Manjaro KDE.

I do not even use KDE (or Konsole profiles for that matter)

and @eddier should perhaps go over the context of this again … :wink:

I had the same issue as the OP - and I think it’s something related to ‘instant prompt’ setting in ‘p10k configure’.

Sometimes when killing and loading dolphin, zsh isn’t loaded - hence the % bash prompt.

Something I never had with KiTTY - so it’s not a Dolphin or a Konsole issue. So this does help with this thread.

I just did ‘p10k configure’ again. The steps, verify font rendering (lock=> debian icon), select unicode rainbow prompt, 12 hour clock, round shapes.

The solution I found was something I didn’t quite understand when doing the configuration the first time - that is the instant prompt. When I set it to QUIET, I found the prompt loaded fine in Dolphin - it’s a while ago, I just changed it to remind myself.

Now Dolphin always loads zsh correctly with the zsh prompt.

So the solution, open Dolphin hit F4, make it bigger…
run p10k configure and at the end choose ‘QUIET’ for the prompt.

Number 2 option…

1 Like

This is due to how different shells interpret different sets of chars.

I suppose Dolphin is using the Konsole engine and this engine can be configured with different interpretations of input - that is bell, lineterminator, newline et al. - which in turn may be interpreted wrongly and thus creates the described inconsistencies.

What I am really saying is - configuration.

I tried powerlevel many moons ago and dropped it because it didn’t work the same way in TTY - you could make it work by implementing framebuffer for konsole but that required setting up a tty service which then created other issues - so I dropped it.

The only prompt config I have come to appreciate is the git prompt - telling me the status - and with oh-my-bash - powerline and zsh has become obsolete to me and I returned to bash.

But even using Plasma I don’t use Dolphin either - I have completely customized my Plasma setup to the bare necessities - and comparing to my previous ‘dislike’ for Plasma I am even beginning to like it.

1 Like

This is not a new issue, but the known issue from a long time ago. It wasn’t fixed yet.

But there are other tricks:

  • Disable heavy Powerlevel, Dolphin will load the source .zshrc and initializes faster.

OR

  • Change the configuration of Dolphin:
    Dolphin → Configure → Startup → Show on startup → Select “/home/yourName”

That is the known bug of Zsh with powerlevel, but Fish shell with tide (like Zsh powerlevel) has no issue.

2 Likes

tried it and it works.
this suggests Manjaro could make changes to work properly out of the box.

I think it’s up to us to set up our own zsh prompt… anyway, I’d strongly recommend KiTTY because it’s really pretty good - I’ve loved Konsole for a long time, but it’s not getting too much airtime ATM.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.