[ BUG ] - VLC player fails to close on manjaro linux

VLC player version ( fails to close when clicking either x in window frame or Quit option from system tray menu, causing next video fail to open.

Temporary video link to illustrate the issue (Youtube Link)

Kernel: 5.9.11-3-MANJARO x86_64 bits: 64
Desktop: Xfce 4.14.3
Distro: Manjaro Linux

In my system with Kde works well. Try deleting ~/.config/vlc folder and ~/.config/vlcrc file , and renaming ~/.local/share/vlc/ folder.

Hi @ddns. I tried your suggestion, but unfortunately that doesn’t seem to solve the issue. I’m still having same problem.

If it’s same bug I have on latest install, stopping video before closing vlc helps. Otherwise pkill -9 vlc
(It’s known vlc bug apparently, I just never seen it before tho.)

Yep, its the latest install. It’s most likely the same issue you and me are experiencing. I’m also using task kill as a workaround on this… Actually to be honest i’m using MPV Media Player as substitution until this bug with VLC gets fixed. Anyway i wanted to shed light on this topic, so other people don’t get confused when trying out Manjaro with default software that comes with it. :beers:

As I said, just try stopping video before closing vlc. You can find topic about this bug on vlc forum. It’s few years long. :stuck_out_tongue:

Another alternative is SMPlayer.

More applications can be found here:

It’s hard to stop playback on short video clips :slightly_smiling_face:

@Wollie Thanks for the suggestion, I’ll check it out :beers:

1 Like

Oh, I only have problem if closing vlc while video is playing. So closing vlc when video is finished playing works fine too.

Yea, i can confirm the same behavior on my machine too.

This problem seem to have been solved with the latest system update. VLC player works as expected now.

I’m still experiencing this issue. VLC, and everything updated in Manjaro KDE