(Bug) Unchangeable Plasma splash screen

Steps to reproduce

  1. Go to System Settings > Appearance > Spash Screen
  2. Set Breeze splash screen and click apply
  3. Restart

Expected behavior

Spash screen changed to Breeze

Remember to click apply.

Also, Splash Screen is the screen that pops up, just after you login and before you get to the desktop. The Breeze one is a KDE logo and a spinner, I think.


It named Spash screen in KDE’s settings

What are you talking about?


I don’t know if it’s the same error I had in a previous topic Unable to select Breeze Start/splash screen

I recently reinstalled KDE several times, it was still a thing. I found several workarounds though.

When Global theme is Breath2, the launched splash/sddm screen is Breath2 if you select Breath2, obviously, but Breeze also.

To launch Breeze Sddm screen, I had to

  • Select Breeze/Breeze dark/Breeze twilight Global theme instead of Breath2
  • Or keep Breath2 global theme and replace the files from Breath2 Sddm by Breeze’s (to repeat after each Breath2 theme update)
1 Like

Yes. It is.

This might be related to the initial post on this thread.
As part of an update today, there was “Manjaro KDE settings”. I rebooted and my splash screen was changed to Breath 2. I checked in to seen if the new splash screen was selected there. My old splash screen was still shown as selected. I selected another, clicked on “Apply”, then reselected my old splash screen and clicked on “Apply”, logged out and all was back to normal.
Very annoying behavior.
As an aside, did a search on the internet for the location of KDE’s splash screens, could not find anything. They are not in the .Plasma folder. Perhaps someone could point me to the location they are stored.

Feel free to search into /usr/share/plasma.

And I’ve learned Global themes are fairly broken. To achieve the wanted result, it’s best to pick each configuration individually (splash screen, icons, …) rather to rely on Global theme.

No matter which Global theme is set, you can anyway change all the individual settings you want (except if you want KDE default splash screen, which is overwritten if you select other than Breeze Global theme)


This is no different than local/share/plasma.
In /usr/share/plasma I found a folder name ksplash, there I see these folders “Classic” “Minimal” and “None”. It is still a mystery to me where KDE hides the splash screens.

I usually select a Global theme, then change items, such as icons, cursors etc…
I don’t see how to choose for instance “Global Theme None”. From what I can see the option is to select a Global Theme, then change the elements individually. “None” would be a welcome option.
Thanks for the suggestions.

@Falav Found them. The Splash Screens are stored in the individual folders for each Global Theme.
Was not too hard to find, all it took was a few sips of a nice cold brew. :beer:

Yes exactly, you have icons, splash screens… All Global theme related components.

If you install a global theme manually you should ensure that at this line:
X-KDE-PluginInfo-Name= in the metadata.desktop must be the same as your Global-Theme-Directory, Plugininfo will write what is our spash theme to spash config file in ~/.config/ksplashrc