[bug report] pamac ignores its "hide tray icon when no update available" preference

The icon is shown always, no matter are there updates avail. or everything is updated.

pamac version
$ pacman -Qi pamac-common
Name            : pamac-common
Version         : 10.0.5-1
$ pacman -Qi pamac-tray-icon-plasma 
Name            : pamac-tray-icon-plasma
Version         : 0.1.2-4
sys info
Operating System: Manjaro Linux
KDE Plasma Version: 5.21.2
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Kernel Version: 5.11.6-1-MANJARO
OS Type: 64-bit
Graphics Platform: X11

No issue here on any of my installs.
In Configure System Tray > Entries make sure the Package Manager is set to Show when relevant and then in Pamac > Preferences is set to Hide tray icon …

If there is AUR enabled and there are updates for some AUR package, then the tray icon will show.

1 Like

Hi, @bogdancovaciu!
Thx for trying to help.

Yeah, or course if no any update including from AUR, so when icon is not red but white.

A few months ago I remember for 100% sure that the “hide tray icon …” pamac’s preference was working like this:
when KDE’s System Tray component has checked Always show all entries on the Entries tab, the pamac’s tray icon was not shown if no update available. The icon starts to show only red-colored. I like that behaviour.

Could you tell me please:

1) does this behavior changed to move to hidden section only instead of older behavior of removing pamac’s icon from system tray entirely?

2) how can that old behavior can be restored?


I had to kill the tray icon and relaunch it after ticking the box in pamac settings in order to get the intended behaviour. In Plasma settings, the tray icon is set to be shown when relevant.

Hi, @Jaypee

Which behaviour is intended? Is it documented somewhere? Pamac - Manjaro lacks it.

What DE are you running it on?

I ticked the box in pamac preferences to hide the tray icon when there are no pending updates, and have the tray behaviour set “Shown when relevant” in Plasma’s settings for tray icons :confused: