[BUG] Manjaro Deepin nasty enter system without password bug

deepin

#1

Good day everyone!
My first post in Linux journey, i’m really pleased with Manjaro experience so far)

Seem to find an easily reproduceable bug.

When i go to account & select option:
Enter system without password

And then Exit as user, instead of usual password screen there is Enter button, which does absolutely nothing, and also shutdown / reset options doesn’t work either, so only option there is to hard reset.

I reproduced it in VirtualBox, after real machine, it acts exactly same so i doubt it’s hardware or keyboard related.

Kernel 4.19.13-1 LTS

Not a big deal, since only i use this option anyway it seems, but still would be cool if there’s some fix :smiley:

P.S. Checked latest non-manjaro Deepin doesn’t have this though, after pressing Enter button just logs in as usual.

inxi -Fxxz from one of hardware tested computers:

System:    Host: x133-pc Kernel: 4.19.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Deepin 15.9 
           tk: Qt 5.12.0 wm: DeepinWM dm: LightDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Sony product: VGN-Z11VRN_B v: J003DTPY serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Sony model: VAIO serial: <filter> BIOS: INSYDE v: R5031M3 date: 11/10/2009 
Battery:   ID-1: BAT0 charge: 33.9 Wh condition: 33.9/59.5 Wh (57%) volts: 12.3/10.8 model: Sony Corporation 
           serial: N/A status: Full 
CPU:       Topology: Dual Core model: Intel Core2 Duo P9500 bits: 64 type: MCP arch: Penryn rev: 6 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 10113 
           Speed: 2527 MHz min/max: 1600/2533 MHz Core speeds (MHz): 1: 2527 2: 2527 
Graphics:  Device-1: Intel Mobile 4 Series Integrated Graphics vendor: Sony driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:2a42 
           Display: x11 server: X.Org 1.20.3 driver: modesetting alternate: fbdev,intel,vesa resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express v: 2.1 Mesa 18.3.1 direct render: Yes 
Audio:     Device-1: Intel 82801I HD Audio vendor: Sony driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:293e 
           Sound Server: ALSA v: k4.19.14-1-MANJARO 
Network:   Device-1: Intel 82567LM Gigabit Network vendor: Sony driver: e1000e v: 3.2.6-k port: 7100 bus ID: 00:19.0 
           chip ID: 8086:10f5 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR928X Wireless Network Adapter vendor: Foxconn driver: ath9k v: kernel 
           port: 7000 bus ID: 06:00.0 chip ID: 168c:002a 
           IF: wlp6s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.39 TiB used: 143.27 GiB (10.0%) 
           ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541515A9E630 size: 1.36 TiB speed: 3.0 Gb/s serial: <filter> 
           ID-2: /dev/sdb type: USB vendor: Kingston model: DataTraveler 3.0 size: 28.88 GiB serial: <filter> 
Partition: ID-1: / size: 172.02 GiB used: 8.41 GiB (4.9%) fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 207 Uptime: 3h 58m Memory: 3.78 GiB used: 525.0 MiB (13.5%) Init: systemd v: 239 Compilers: 
           gcc: 8.2.1 Shell: bash v: 4.4.23 running in: deepin-terminal inxi: 3.0.28 


The lockscreen on my manjro deepin laptop is not working properly
#2

already an existing thread for this issue.

also: i could be wrong but i think they released another deepin iso that fixed this


#3

Oh ok, would be cool then. Then hopefully manjaro will update it soon…

But at the same time i enountered different problem than this video (seen it btw).

Maybe it’s connected, but still, mine is that:

  1. [v] Enter without system password
  2. Logout
  3. On attempt to login - can’t do absolutely nothing except hard reset:
    1. Enter button is completely inactive doesn’t matter if i wait or how many times try
    2. Change user do nothing like in video (i also have single user btw)
    3. Shutdown / Reset options also do nothing in this screen

That guy at least could do this security flaw bug to get back to system :smiley:
Besides he used block, i used logout…

So i guess moral of the story is that logout bug is more secure than block bug, since you can’t log to system anymore :slight_smile:


#4

Latest update for Linux Deepin de claims to fix this bug (haven’t tested personally), but good to know :slight_smile:


#5

After yesterday updates it’s a bit better. now shutdown / reboot works.

But login button still do nothing


#6

This is correct, as you’re ■■■■ out of luck if you’re trying to boot into your installed system. If that bug has been crushed, Manjaro is in need of a new Deepin iso.

GM


#7

After latest updates this bug still active, login button does nothing.

Manjaro Deepin only as of today Deepin doesn’t have it.


#8

Login button still does nothing after 10.02.2019 update :worried:
Come on, this is serious one.