Bug KDE Plasma or Manjaro

Hello, there has been a bug for a long time in plasma, since version 5.24 I have been noticing it and perhaps it has been around for a long time, I have a 15" laptop and an extra 19" monitor connected, I have the monitor as the main one. And the system programs like fit and dolphin when I run them open on the extra monitor, but with the dimension of the laptop screen, (very small), I make it bigger and when they reopen they reopen with the dimension of the laptop screen. If there is any solution to correct, I would appreciate it. Thank you…

Hi @Benjamin8a,

I don’t think it’s a bug. I think it’s a setting. Double-check in:

System SetttingsWorkspaceStartup and ShutdownDesktop Session. On that screen ensure Restore previous saved session is selected:


Hope this helps!

This is on plasma 2.24, but I’m sure the process and/or setting is nearly identical in 2.25.

Sounds to me you just want to have them open to a specific size. If that’s the case easily done.

Launch the app
size it to your liking
right click it’s titlebar (some apps you will have to do Ctrl+F3 while you mouse is sitting on the apps titlebar)
in the menu that pops up select configure special application settings
take the settings box that opens and place it over the app and make it the same size as you app window
now click detect window properties and you’ll get a + sign
click detect window properties again
now in the pop up you can chose size, position, etc
select size
close add property to the rules dialog
now back on the main application settings window set the size option you added to apply initially

1 Like