Bug for multi-monitor with different refresh rate after sleep

Hi, I’m using manjaro xfce, my laptop refresh rate is 240hz and usually I’ll connect to a monitor with 60hz refresh rate.

I set my laptop at 240hz and monitor at 60hz and do the following:

  1. Wait until the system closes the screens and sleep.
  2. Wake the laptop up

Then the laptop screen (240hz) will appear a bug and shows the following:

There is no problem when I set the laptop screen to 240hz and it also works fine with windows 11 on different refresh rate.

So I guess it is a software bug and want to ask how to fix it since manjaro is my main system and I also play games on it.

The following is my system info:

[shore@shore-82wm llvm_learn]$ inxi -Fxza
  Kernel: 6.7.7-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: hpet avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.7-x86_64
    root=UUID=94ce18fb-e81a-4932-bae3-1f9db27168c9 rw quiet splash
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: xfce4-panel tools: xfce4-screensaver vt: 7 dm: LightDM v: 1.32.0
    Distro: Manjaro base: Arch Linux
  Type: Laptop System: LENOVO product: 82WM v: Legion R9000P ARX8
    serial: <superuser required> Chassis: type: 10 v: Legion R9000P ARX8
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76479 WIN
    serial: <superuser required> part-nu: LENOVO_MT_82WM_BU_idea_FM_Legion
    R9000P ARX8 uuid: <superuser required> UEFI: LENOVO v: LPCN47WW
    date: 09/15/2023
  ID-1: BAT0 charge: 80.8 Wh (95.1%) condition: 85.0/80.0 Wh (106.2%)
    volts: 15.9 min: 15.4 model: COSMX L22X4PC0 type: Li-poly serial: <filter>
    status: full cycles: 1
  Info: model: AMD Ryzen 9 7945HX with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 4 gen: 5 level: v4 note: check built: 2022+ process: TSMC n5 (5nm)
    family: 0x19 (25) model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
  Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
    L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 16 MiB desc: 16x1024 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 787 high: 3593 min/max: 400/5461 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 3592 2: 400 3: 400
    4: 400 5: 3416 6: 400 7: 3399 8: 400 9: 400 10: 400 11: 400 12: 400
    13: 400 14: 400 15: 400 16: 400 17: 400 18: 400 19: 3593 20: 400 21: 400
    22: 400 23: 400 24: 400 25: 400 26: 400 27: 400 28: 400 29: 400 30: 400
    31: 400 32: 400 bogomips: 159760
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB:
    conditional, STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile] vendor: Lenovo
    driver: nvidia v: 550.54.14 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2024-02) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022+ pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.0 chip-ID: 10de:28e0
    class-ID: 0300
  Device-2: Syntek Integrated Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2.4:5 chip-ID: 174f:246a
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.org v: compositor: xfwm4 v: 4.18.0
    driver: X: loaded: nvidia gpu: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 7680x1600 s-size: <missing: xdpyinfo>
  Monitor-1: DP-1 pos: right res: 2560x1440 hz: 60 dpi: 109
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  Monitor-2: DP-4 pos: left res: 2560x1600 hz: 60 dpi: 188
    size: 345x215mm (13.58x8.46") diag: 407mm (16") modes: N/A
  Monitor-3: HDMI-0 pos: primary,center res: 2560x1440 hz: 60 dpi: 109
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.54.14
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 4060 Laptop
    GPU/PCIe/SSE2 memory: 7.81 GiB
  Device-1: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s
    lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:22be class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
    driver: snd_rpl_pci_acp6x v: kernel alternate: snd_pci_acp3x,
    snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh,
    snd_sof_amd_acp63 pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 08:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 08:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.7.7-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    vendor: Lenovo driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
    bus-ID: 04:00.0 chip-ID: 14c3:0616 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 1000 bus-ID: 07:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: Foxconn / Hon Hai Bluetooth Adapter driver: btusb v: 0.8 type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1.1:3
    chip-ID: 0489:e0d8 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 2.75 TiB used: 448.84 GiB (15.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVL21T0HCLR-00BL2 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: EL1QGXA7 temp: 41.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:6 vendor: Seagate
    model: WDC WDS200T2B0C-00PXH0 size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 21705000 temp: 36.9 C scheme: GPT
  ID-1: / raw-size: 1.82 TiB size: 1.79 TiB (98.37%) used: 448.84 GiB (24.5%)
    fs: ext4 dev: /dev/nvme1n1p2 maj-min: 259:8
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 300 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:7
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 96 GiB used: 0 KiB (0.0%) priority: -2
    file: /var/swapfile
  System Temperatures: cpu: 64.8 C mobo: 46.0 C gpu: nvidia temp: 40 C
  Fan Speeds (rpm): N/A
  Memory: total: 48 GiB available: 46.73 GiB used: 9.96 GiB (21.3%)
  Processes: 534 Power: uptime: 6m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 18.67 GiB
    services: upowerd,xfce4-power-manager Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1387 libs: 395 tools: pamac Compilers:
    clang: 16.0.6 gcc: 13.2.1 Shell: Bash v: 5.2.26 running-in: code
    inxi: 3.3.33
[shore@shore-82wm llvm_learn]$ xrandr
Screen 0: minimum 8 x 8, current 7680 x 1600, maximum 32767 x 32767
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 connected 2560x1440+5120+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440     59.95*+  74.97  
   2048x1080     60.00  
   1920x1080     60.00    59.94    50.00  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1280x720      59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    59.94    59.93  
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 2560x1440+2560+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440     59.95*+  74.97  
   2048x1080     60.00    24.00  
   1920x1080     60.00    59.94    50.00    25.00    23.98  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1280x720      59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    59.94    59.93  
DP-4 connected primary 2560x1600+0+0 (normal left inverted right x axis y axis) 345mm x 215mm
   2560x1600     60.00*+ 240.00  

You might try setting suspend as your sleep state rather than hibernate.

You will possibly see some imporovement after reverting to kernel 6.6.x - See Manjaro Kernels.


1 Like

Hi, the problem is found under 6.6.19-1, I just want to try if 6.7 fixed this and seems not…

I don’t know if this is well known - but I know it from experience.

I have been able to run a Samsung Odyssey NEO G9 240Hz and Acer 144Hz display at the same time but only after buying high quality display port cables cable of running 144Hz. HDMI although also high quality was not enough. (Intel CPU and AMD WX7100 PRO)

My system is different now with a Lenovo P620 Workstation and RX 7900XTX and only the Odyssey display.

If that for any reason is not an option I can only offer speculation

Connection is often the weak link

  • connection cable must be of high quality

This is one may not be relevant as it relates to kwin

1 Like

Hi i also tried to set sleep mode to suspend, cannot fix this

Hi, I have my laptop screen which is 240hz and 2 monitor connected which runs at 59.95hz

It may not be the connection issue since they work fine under windows 11

Windows does not equal Linux - and does not always support the same setup - that is just how it is and you cannot assume that Linux will work the way you intend.

And Linux is more self serviced - but as I said only speculations.

What happens if you set the laptop display at 60Hz?

However I do think Plasma on Wayland provides better support with AMD hardware.

On some personal experience - my past experience with AMD dates back 20y - and that was not great.

I thought if Lenovo builds a workstation like the P620 - it can’t go wrong - and I got hooked on AMD and just yesterday I got a new Lenovo X13 with AMD 7940U added to the collection (no OS so I am starting from scratch). I am looking forward to experience this from ground up.

1 Like

60hz is OK.

One more thing I found when my laptop on 60hz, the inxi -Fxza returns info with refresh rate:

  Monitor-2: DP-4 pos: primary,left res: 2560x1600 hz: 60 dpi: 188
    size: 345x215mm (13.58x8.46") diag: 407mm (16") modes: N/A

While on 240hz, it does not return a refresh rate and all the parameters are wrong…

  Monitor-2: DP-4 pos: primary,left res: 2560x1600 dpi: 4064
    size: 16x10mm (0.63x0.39") diag: 19mm (0.74") modes: N/A

Linux is much about finding the right configuration - and in doing so - sometimes requires a great deal of searching - reading - refine search - reading more - and suddenly - bam - there it is - a user having almost the same issue and while that user’s solution do not work in this case it hints you to the tweaking point.

Almost like tuning engines - there is a lot of adjustment options - which one is the right one to push that extra mile?

The link from above about color depth - refers to a kernel limitation - one should speculate the 6.8 perhaps even 6.9rc provides improvements in that regard.

I saw 6.8rc, let me try for that…

I’ve googled and read every post in forum, still cannot find any clue…

Aha - you must be on stable - in unstable 6.8.2-2 and 6.9 is rc2

I just build a plasma6 iso with 6.8 for the x13

If you need an option to test I can give you the link

Let me try first since I can easily install it by majaro setting manager…

I may stay on 60hz if that does not work…

I also think there may be some clue on wrong parameters with inxi -Fxza:

  Monitor-2: DP-4 pos: primary,left res: 2560x1600 dpi: 4064
    size: 16x10mm (0.63x0.39") diag: 19mm (0.74") modes: N/A

The dpi, size and diag are all wrong…

seems not work, I saw some other post saying that it may due to X.org, I’ll try to install gnome instead of xfce to try…

So bad, the kde displays black screen after update all packages, tried 2 times…use back xfce…

anyone has any idea???

I presume you tried KDE by performing a fresh install of the Manjaro KDE distribution, right? If you installed the KDE Display Environment on top of your existing XFCE, then that could produce unpredictable results.

Another plus for KDE is that Wayland is now the default DE; and you are able to switch between Wayland or X11 at the login screen.

It would be interesting to know if similar issues persist for you in both Wayland and X11, or whether its limited to only one of these.


I actually wipe out the whole system and reinstalled…

After I update all the packages and installed nvidia drive and reboot, it only shows the majaro welcome window and black screen…

That sounds like another issue entirely. There are (Manjaro-specific) tutorials for installing Nvidia drivers properly; you just need to search for them. I don’t use Nvidia (never will) so I don’t keep any links handy.

Blackscreen is likely caused by missing early kms.

Nvidia must enable this using a cmdline argument while AMD works OOB

I just installed with manjaro setting manager, auto-install