BSPWM won't start [Solved]

So, here’s the thing, I’ve got Gnome uninstalled and after that BSPWM won’t start.
Strangely enough, I can start with other WM (now in DWM or Deepin)

I was wondering what I touched to make this authentic mess!
I don’t know where to start

For starters neither gnome nor deepin are windows managers (both are desktop environments ~DE). When you install multiple DE’s you run the risk of getting a lot of over lapping “features” & “functions”. Given we have no actual idea of what you “really” did it is hard to guess why you have such a mess.

Yes, they are DE. So, now that I messed it up, I want to figure out how to redo the issue. It might be a problem with the autostart file, but I’m not sure.That’s why I’m asking here.
I’d like to know if there’s a way to to know what happens (a log) after I type my user password on my lightdm screen.
By the way, I messed a lot with DE and WM, they are addictive :smiley: but, strangely, I never had this issue before (I had other issues, though!)

Given you haven’t explained what you did, you have provided no errors, you have not shown your hardware platform specs…

Here’s what I can offer by way of help.
1.Save your data somewhere… then
2. Wipe the machine clean (optional)
3. Perform a fresh reinstall.

In the future you might want to be a bit more circumspect, save an audit trail, and watch (and plan) for potential pitfalls.


bspwm is among the difficult WMs to set up from scratch.

I would start by backing up your data (texts, pictures, videos, browser bookmarks) and reinstalling from manjaro-architect.

Manjaro flavour of bspwm also was developed more for standalone operation. I always had to perform several settings changes to make it work with other DEs as an additional session.

Alternatively you can try a simpler WM which you can even start from command line: Sway - ArchWiki

did you insall sxhkd? was the bspwmrc file executable?

yep. It’s been installed and working. However later I twiched something and then it stopped loggin in.
What I want to know is the log in menu log so I can spot the problem. That’s what I was asking here. Sorry for not being more concrete!

sounds good the sway thing!

1 Like

Can you post ~/.xinitrc on and give a link here?

here’s the .xinitrc file:

# ~/.xinitrc
# Executed by startx (run your window manager from here)

[[ -f ~/.Xdefaults ]] && xrdb -merge ~/.Xdefaults



# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap

if [ -f "$userresources" ]; then
    xrdb -merge "$userresources"

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"

# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
    for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
        [ -x "$f" ] && . "$f"
    unset f
if [ $TERM = linux ] || [ -e "/etc/systemd/system/$(whoami).service" ] ; then
# Here Bspwm is kept as default

case $session in
	awesome 		  ) exec dbus-launch --sh-syntax --exit-with-session awesome;;
	jwm 			  ) exec dbus-launch --sh-syntax --exit-with-session jwm;;
	deepin 			  ) exec dbus-launch --sh-syntax --exit-with-session startdde;;
	enlightenment 	  ) exec dbus-launch --sh-syntax --exit-with-session enlightenment_start;;
	gnome 			  ) exec dbus-launch --sh-syntax --exit-with-session gnome-session;;
	bspwm 			  ) exec dbus-launch --sh-syntax --exit-with-session bspwm-session;;
    i3|i3wm           ) exec dbus-launch --sh-syntax --exit-with-session i3;;
    lxde 	          ) exec dbus-launch --sh-syntax --exit-with-session startlxde;;
    lxqt         	  ) exec dbus-launch --sh-syntax --exit-with-session lxqt-session;;
    i3|i3wm           ) exec dbus-launch --sh-syntax --exit-with-session i3;;
    kde               ) exec dbus-launch --sh-syntax --exit-with-session startkde;;
    cinnamon          ) exec dbus-launch --sh-syntax --exit-with-session cinnamon-session;;
    budgie            ) exec dbus-launch --sh-syntax --exit-with-session budgie-desktop;;
    mate              ) exec dbus-launch --sh-syntax --exit-with-session mate-session;;
    openbox           ) exec dbus-launch --sh-syntax --exit-with-session openbox-session;;
    xfce|xfce4        ) exec dbus-launch --sh-syntax --exit-with-session startxfce4;;
    # No known session, try to run it as command
    *                 ) exec dbus-launch --sh-syntax --exit-with-session $1;;

thanks for helping

So, here’s how I solved the problem:
As you can see in the code that I pasted you, there’s a command to start bspwm (bspwm-session)
I opened another tty and checked and it seems to be a problem with a non completely uninstalled opt program…
I deleted it, and the error is gone, so I can start the session! thanks a lot!

for learning:
what exactly was the non completely uninstalled opt program?

how did you troubleshoot?

Sure, the problem was that I tried to uninstall the packet tracer that you download from Cisco (I’ve got the AUR working and it’s way better). It consists on a .sh that you run and installs.
When I tried to uninstall it, the script didn’t worked. Then, what I did is just to remove the Packet Tracer files in the /opt directory.
However, I didn’t remove the script that was being run in /etc/profile.d and that was causing the issue.

How I did know that it was this?
I’ve saw how bspwm is launched in the script above and then I switched to TTY (ctrl+alt+f2 to access TTY2) and run the command bspwm-session to see what’s going on.
It showed me this problem, and then I think I solved it by deleting that file inside /etc/profile.d