Browsers have strange behavior on Raspberry Pi 4 4GB


I have installed Manjaro ARM Gnome version on a Raspberry Pi 4 with 4GB. Everything runs smoothly, compliments to the team for that, except for one thing.

Browsers don’t close as they should. To be precise, if I close the browser, it isn’t shown in System Monitor / htop anymore as a process, killall shows it’s not running anymore, but it is still shown next to the Activities button loading, and on desktop the mouse has the loading animation instead of being a regular pointer; it is also still shown in the favorites as open, but when I click on it, nothing happens, only when using “new window”, it starts that.

I tried it with firefox, since it’s the default, and chromium, and both show the same behavior. I thought it might have something to do with ublock origins, but disabling that doesn’t help, neither does refreshing the browser - it would be weird if that worked, since it’s a fresh installation with nothing but all updates installed.

Help would be greatly appreciated. Thanks

Edit. It just fixed itself, no idea how and why, it’s not showing the behavior anymore.

1 Like

Was also facing the same issue with firefox. Dropped Gnome for a while as it kept bugging me. Will try again now that a bunch of packages have been updated

1 Like

Yeah, I realized today it’s doing that sometimes and it isn’t gone entirely. Weirdly enough, starting firefox from terminal seems to make the problem disappear for that session, which doesn’t really make sense, but whatever. ^^