Browser won't use PuTTY connection

I need to make a connection using PuTTY for accessing my work place.
It works well on windows, now I’m struggling to make it work on Linux.

I can connect to the server using PuTTY, connection is up and running.
I did change my /etc/hosts file and added some lines like this:          <hostname1>        # test-server one          <hostname2>        # test-server two          <hostname3>        # test-server three

When I type the hostname in the browser it says This site can’t be reached. <hostname> refused to connect. on Linux.
It works well on Windows.

Anything I can do to make it work?

not sure but i think you have to be group-member of uucp to fully access putty. please post the output of


Thanks, my user was not part of the uucp group.
I added my user to the group and did reboot, but this didn’t change anything.

What does Putty and the hosts file have in common?

I think you forgot the port forwarding in your settings. Why do you need putty anyway and not use ssh directly?

My coworkers all use windows and have no clue about Linux. I know Linux but don’t know much about all those vpn and ssh connections.

I will try to make the connection using ssh instead of putty and see if that makes a difference. Just give me a moment…

The port forwardings are all set in putty, I have to figure out how to do this using ssh.

Note that is your localhost as you know. The VPN is virtual network with a different IP address range. VPN tunnels all requests, but you can still access local network via IP, but not Domains (DNS).

So must be the IP address on the virtual network and not your local network.

I highly doubt that this works like that on Windows with a VPN.

The use of PuTTY implies ssh - at least in my manual :slight_smile:

You cannot make any connection to a remote host with IP - because it is your local system and localhost cannot be routed.

Okay I am now able to set up the connection using ssh (and not putty any more). In the ssh config, I defined several LocalForward entries which I took from the putty configurations.

I reset my hosts file to what it was before I changed it, because, like you said, those entries don’t look like they make any sense at all.

Now I have to open up a web site which should be accessible through my ssh connection, but my browser keeps showing me a <domain name>'s server IP address could not be found.

How can I tell my computer now, that when I want to open this one web link, it should get it through the ssh connection?

I did that by setting these entries in my ~/.ssh/config file:

    ForwardAgent yes
    LocalForward 443 <remotehostname>:443
    LocalForward 8080 <remotehostname>:8080

To make ssh able to forward port 443 I have to run it using sudo.

But still when I try to access <remotehostname> in the browser it can’t find the site.
When I set proxy settings in firefox to for port 8080 and 443 I am able to access some kind of result from <remotehostname> through http, but not through https, which I think is the one I actually need.

So I feel like I am getting really close now, but need one last step to make it through!

edit: To make that clear, after connecting to my ssh server, all my network traffic seems to not use this ssh connection. I can tell this as my public IP address is still the same.

Are you confusing ssh with VPN?