Browser (Librewolf) keeps re-setting my defaulted file manager

I use LIbreWolf browser (via Flatpak). So that my default file manager is set to Dolphin (I would LOVE to just change Manjaro so Dolphin is the default anywhere in the system).

WHen I do downloads - and select ‘show in folder’, or just looking at downloaded files - Nemo is always opened… If I add this line: inode/directory=dolphin.desktop; to the mimeinfo.cache file (in directory: home/admin/.local/share/applications - I can get Dolphin to be used.

However - that file keeps getting rewritten and that line is removed…

So - my questions are:

  1. why is that file being rewritten, by what? (not related to updates)

  2. Is there not a way to just get rid of Nemo and have Dolphin be my primary (only) file manager across all of my system?

Nemo is the default file manager in Gnome.
Why would you even have Nemo available as a choice if you are using KDE (as this posts tag implies)?

1 Like

I must have installed Nemo and Nautilus a long time ago… had no idea.

I’ve now removed both… and the problem is resolved.

Please mark the answer that helped you resolve the issue.

I will also add that given the commentary here … you may wish to revisit a few things.

  • Manual File (may not be required, but maybe check): ~/.config/mimeapps.list
  • System Settings > Default Applications > Default Applications > File Browser
  • You may want to check on the status/config of your portals

Thanks - made sure Dolphin is my default file browser - Portal config looks to be ok…

All working as I’d hoped!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.